Question Asrock x570 steel legend BIOS Flashback???

Apr 6, 2021
7
0
10
0
Hello Everyone,

This is my first amd build and have never had any issues before with a PC build but can't seem to get the pc to post.
As I have eliminated all parts to be working fine apart and are compatible with this motherboard I can't get it to post.

I belive it comes down to the BIOS needs updating.
I have tried the cmos battey as I didn't get a jumper but still nothing.

Does anyone know if the x570 steel legend motherboard can do USB flashback and if so how can I do this?
I have checked the manual and asked asrock support but not heard anything back.

Thanks for reading.
Jamie
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

We're going to need a little more information. Please list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

As for the motherboard, you should be seeing a sticker that is meant to designate what BIOS version the board came shipped with from the factory. Apparently the board doesn't seem to have any form of BIOS flashing utility onboard, it should have it but it's not stated on the specsheet or the manual.
 
Apr 6, 2021
7
0
10
0
Hello, yes I am very stuck with this aha.

Amd 3900k
Asrock x570 steel legend
Corsair vengeance led 64gb x4 slots
WD 1tb m.2 ssd
Msi Gaming 480x 8gb I belive.
Corsair rm850x white
Corsair 4000x
No OS currently as cant post to install it.

Have checked everything over and is all compatible and have also check parts on there own and say working.

The on board pcu has confirmed all parts are working as well but the boot led stays on so still don't know.

Thanks Jamie
 
Apr 6, 2021
7
0
10
0
Hello,

Yes everything is hooked up correct. I have done loads of Intel builds but this is my first amd build, not had any issues with other pc's I've built.

Tried a different psu and with ram, without and single ram etc but still getting the boot issue.

Thanks Jamie
 
Apr 6, 2021
7
0
10
0
I doubt it has a dead battery, given how it's not that old.
Yer didn't really think it would be that but never know. No luck with a boot. I'll leave the pc running for a bit just to see if it kick in maybe.

If not then I guess I'll have to wait till a PC shop opens as I am dead for ideas now.

Tried everything I could find on Google 😂
 

ASK THE COMMUNITY

TRENDING THREADS