Question Asrock Z390 Extreme4 Audio issues: crackling/popping and disappering sound

Feb 14, 2019
1
0
10
0
Hi guys!

I have a really weird problem with my Realtek Audio on my ASRock Z390 Extreme4 mobo in Windows 10. The sound is always working perfectly after booting the system up. I am using the rear analog jack output and have my analog LG speakers connected. Then, after some time, the sound mysteriously disappears. Actually, it never happened while the system was playing sound at the moment but that might be just a coincidence. Anyway, when the sound disappears, the rear jack output simply stops working.

The weird thing is that the front panel (connected from the case to the mobo with an HD audio cable that comes with a case) is still working - when I connect headphones, I can hear the sound, but it's distorted - kinda crackling, popping noises come up. Normally, before the disappearance of the rear jack sound happens, it works perfectly (no popping sound from the front panel). More interestingly, when I disconnect my speakers from the rear jack output, crackling from the front panel disappears... When this all happens, it's absolutely impossible to make the rear output jack work again. I've tried deactivating sound controller by disabling it and re-enabling in the Device Manager, restarting Windows Sound service, scrolling the volume slider in the system tray, changing playback device (you can choose between speakers and digital audio which I do not use). Everything to no avail...

And here is the interesting part: when I restart my Windows, the sound comes back. Also - when I put the computer into sleep and then turn it on, it also comes back. So this suggests it could be a driver issue, right? But I'm not really sure if I can rule out a hardware malfunction. Please help! Attached please find detailed specs as well as all steps I've tried in order to find out why it's happening and how to fix it.

Specs:
  • i9-9900K; no OC
  • CPU Cooling: Noctua NH-D15S
  • MOBO: ASRock Z390 EXTREME4
  • RAM: HyperX Predator RGB, DDR4, 16 GB, 4000MHz, CL19; no OC
  • SSD Samsung 860 EVO 500GB SATA3 (for system)
  • SSD Samsung 860 EVO 2TB SATA3
  • SATA Seagate Constellation CS, 3.5'', 2TB, SATA/600, 7200RPM, 64MB
  • Graphics: Gigabyte GeForce GTX 1050 2GB; no OC
  • Power supply: be quiet! Dark Power Pro P11 650W
  • Cabinet: Corsair Carbide Series 300R Compact Black; 2 fans in the cabinet
  • Monitor: LG 27 UK650-W - x2
  • Windows 10 Pro EN 64-bit OEM - legal; activated; all updates installed
As you can see the specs is decent - no cheap components etc.

I've found some events in the Application section of Event Viewer but they are probably meaningless and will not help much:

Code:
Faulting application name: AUDIODG.EXE, version: 10.0.17763.292
Faulting module name: unknown
Exception code: 0xc0000005
Faulting module path: unknown
More information on what I've done and checked out:
  • I do not OC anything. All settings in BIOS are set to default
  • CPU temps are within the range of 30 (idle) to 75 degrees when all cores have 100% load
  • BIOS is updated to the latest possible version from ASRock website
  • all drivers are updated to the latest possible releases from ASRock website as well
  • Windows 10 is legal & activated. No viruses
  • CPU has been stress-tested with Prime95, Intel Extreme Tuning stress test for 4 hours - no issues
  • RAM has been tested with memtest86 for 8 hours; no issues
  • sfc /scannow has been performed; no errors; the system is stable - no bluescreens and bugchecks; no unexplained entries in the Event Viewer;
  • No weird software installed - in fact only a few programs on board: Visual Studio Community, Adobe Lightroom, Adobe Photoshop, Chrome, Open Office. No bloatware of any kind
  • DPC latency is perfect (<200 us for most requests, and only a few within the range of 200-500 us), tested with Latency Monitor
  • rear jack port and front jack port are working properly; speakers are also working perfectly with the other computer I have
  • all audio enhancements are disabled
  • Realtek Audio Console shows the rear speaker port is properly connected; the impedance is detected properly; front panel detection is working (shows when I connect my headphones)
 

ASK THE COMMUNITY

TRENDING THREADS