Question ASRock Z390 wont post

Jun 29, 2020
2
0
10
0
Hi.

I just put together a build but it wont post. I know the ram is good, because I have another system built on a Z370 Pro4 that has been working great, and I swapped out the ram between the two systems. Both sets of RAM worked on the Z370 so I know they are good. so I know the RAM is fine.
All the fans are working. No beeps, just a steady pulse of the blue lights on the motherboard.

I know this board at one time worked fine because I installed it on the other system until I realized I needed a different PCI slot so I got the Z370 and used that. So the Z390 should work.

So, I read a bunch of email from this site and the ASRock technical support forums and none of the proposed fixes seem to apply. So I am asking for help.

For power-from my PSU (see below) I attached a 8-pin CPU cable to the ATX12V1 connector, a 24 pin cable to ATXPWR1. FWIW, I did not connect anything to the 4-pin ATX12V2 connector, I dont blieve i need to and I I don't have another CPU cable anyways. None of my CPU cables form my PSU had 4 pins anyways.

When I supply power from the PSU the blue lights on the motherboard start to pulse maybe once per second.
When I press the power button on the IO panel all the fans (case fan, CPU heat sink fan, and GPU fans stat up. The only think I hear is the tiny amount of crinkling that IIRC is a hard drive starting up.
I get no output from my GPU. No beeps no sound, just the fans running and the steady pulse of blue lights.

I hear NO beeping at all. The IO panel connectors seem to work fine - I have IO panel lights and the power switch starts the CPI and GPU fans.

This is my build:
ASRock Z390 Extreme 4
Intel I9-9900KF (coffee lake) CPU - no onboard graphics.
Corsair Vengeance LPX DDR4 2x16GB (32GB) 3200 MHZ
Hyper 212 EVO heatsink/fan.
Gigabyte GEForce RTX 2060 Super Graphics card
Corsair RM850 power supply.
Fractal Designs Define R5 case.
Crucial MX500 SSD
Seagate Barracuda SATA Hard drive.

According to this support page my CPU should be supported:
https://www.asrock.com/MB/Intel/Z390 Extreme4/index.asp#CPU

I really haven't seen any means of diagnosing the issue.

Thanks for all suggestions/advice,

Fraser
 
Jun 29, 2020
2
0
10
0
Thanks for the reply. You mean the CPU socket, right? It looked OK to me.
I dont know how to determine what the BIOS is on the motherboard. How does one do that it you can get it to boot at all?
 

ASK THE COMMUNITY