ASRock Z68 Extreme3 Gen3 - BIOS elements missing?

Infrantic

Distinguished
Sep 7, 2011
58
0
18,630
I recently got a Z68 Extreme3 Gen3.
I am trying to overclock my i5-2500K on this board, but when I go into BIOS all I get is this:

(sorry for the shitty quality, couldn't get the screencap feature to work in BIOS)
BIOS.jpg




These are not NEARLY the options stated in the Motherboard manual or from any other screenshots I've seen of the OC Tweaker tab in BIOS.
I'm missing tons of elements like "Load Optimized CPU OC Setting" and so on.

Anyone has any idea what the issue is? Is this just me being a noob or something else going on?
 
Solution
Disable advanced turbo 50, that's the auto oc function which is why it's hiding the other options. It should've been off by default, mine was.

Infrantic

Distinguished
Sep 7, 2011
58
0
18,630
I've run through all the settings and tabs in BIOS several times before but nothing seems to bring more options to the OC Tweaker tab.
I will try and run through everything again and see if I missed something :)
 

Infrantic

Distinguished
Sep 7, 2011
58
0
18,630
I went through everything I could find, but nothing seemed to add anything else in the OC Tweaker tab.

Though I noticed something strange, in the BIOS my CPU shows up at 4800MHz. I then checked CPU-Z and ASRock's own AXTU.

This is what I got;

OC.jpg


In CPU-Z it seems to be switching between 1596MHz and 4790MHz, I've read that this could be eliminated by disabling Speedstep in BIOS which I did to no avail.
And in ASRock Extreme Tuner it shows up as 4800MHz just like the BIOS.
I also checked dxdiag and that shows it at 3.30GHz, but I'm not sure how reliable that is?

EDIT: It seems like k1114 answered this post while I was typing it. I'm gonna try that, thanks for the tip :)
 

TRENDING THREADS