Question Assassin's creed unity Lag fixed

Mar 28, 2019
19
0
10
0
Here are my specs
Gtx 760 2GB
8gb ddr3 @1333 mhz
I5 2400
2tb hdd
DH67CL MOTHERBOARD
Win 10 64 bit
600 W psu

My game freezes ... After some time and then i have to restart my pc to get to desktop
 
Last edited:

Phaaze88

Honorable
Herald
No one can just give you those numbers. No 2 cpus/gpus/memory kits overclock the same. It all depends on the quality of the silicon under the hood.
Even if you looked up someone else's gpu OC profile, there's no guarantee yours would run at the same settings.
Besides, overclocks aren't a massive improvement in performance - up to a few percent, maybe?
You need to upgrade your current hardware.
 
Mar 28, 2019
19
0
10
0
No one can just give you those numbers. No 2 cpus/gpus/memory kits overclock the same. It all depends on the quality of the silicon under the hood.
Even if you looked up someone else's gpu OC profile, there's no guarantee yours would run at the same settings.
Besides, overclocks aren't a massive improvement in performance - up to a few percent, maybe?
You need to upgrade your current hardware.
I replaced my thermal paste yesterday
 
Mar 28, 2019
19
0
10
0
I fixed it myself i found that ac unity's lag is caused due to excessive amount of people as they all have AI . The proff for this statement is you will never lag at rooftops until you try to swing mouse towards people , the mostly poplated areas lag more rather than graphically intensive areas well I couldn't counter that but i have a solution

Ingame settings
Res-900p1440900 or 1600900
Environment quality- high
Texture quality- high
HBAO+
Shadows-high
Bloom- on
Fxaa






Go to nvidia control pannel
Dsr 4Xnative
Dsr smoothness 100

Program settings ACU.exe
Prefer max performance
Turn on low latency mode
Vertical sync half the refresh rate
Virtual reality pre rendered frames 2-4 (i am still testing)
Triple buffering (test it yourself)
And
Then open msi after burner
+50 core clock
+400 mem clock

And now i am currently testing new speeds
+60
+550
That's all and if some genius guy finds a code to reduce population density this game would run wayyy smoothly

You lag will mostly be fixed but you will experience mini spikes sometimes but its playable and you will be able to enjoy the story of the game like you used to for assassin's creed 2 and black flag
 
Mar 28, 2019
19
0
10
0
I fixed it myself i found that ac unity's lag is caused due to excessive amount of people as they all have AI . The proff for this statement is you will never lag at rooftops until you try to swing mouse towards people , the mostly poplated areas lag more rather than graphically intensive areas well I couldn't counter that but i have a solution

Ingame settings
Res-900p1440900 or 1600900
Environment quality- high
Texture quality- high
HBAO+
Shadows-high
Bloom- on
Fxaa






Go to nvidia control pannel
Dsr 4Xnative
Dsr smoothness 100

Program settings ACU.exe
Prefer max performance
Turn on low latency mode
Vertical sync half the refresh rate
Virtual reality pre rendered frames 2-4 (i am still testing)
Triple buffering (test it yourself)
And
Then open msi after burner
+50 core clock
+400 mem clock

And now i am currently testing new speeds
+60
+550
That's all and if some genius guy finds a code to reduce population density this game would run wayyy smoothly

You lag will mostly be fixed but you will experience mini spikes sometimes but its playable and you will be able to enjoy the story of the game like you used to for assassin's creed 2 and black flag
Now i found a way to even reduce the no of npcs
Check this link
https://steamcommunity.com/app/289650/discussions/0/618457398972494286/?ctp=2
 

ASK THE COMMUNITY

TRENDING THREADS