Question Asus AiMesh using 2 RT-AC68U routers - 5Ghz and 2.4Ghz wifi routing randomly gets ultra-slow or stops ?

xenon2000

Distinguished
May 2, 2008
83
0
18,640
1
I just recently added a 2nd router and enabled AiMesh. I now have 2 Asus RT-AC68U routers with the latest firmware as of last week. Firmware 3.0.0.4.386_43129 , one is of course the master router and the 2nd one is setup as an AiMesh node. I have the node using a 1Gbe LAN backhaul connection back to the master router and shows Connection quality as Great. Which is just talking about the backhaul connection.

On the node, currently only 1 device on 5Ghz and 1 device on 2.4Ghz. When I walk over to that end of the house it will then show my phone as a 2nd 5Ghz device. I have only tested the issue on my Samsung S9 Plus.

wifi speed test shows I get over 300Mbps down and 38Mbps up with a ping of 15ms. The 300+ down is the max of my phone's wifi. Cox ISP provides about 940Mbps down and 35Mbps up. Everytime I do a speed test the phone shows everything is great regardless of being connected to the master or node. Everything was working great before Using AiMesh, I just had spotty coverage on the far end of the house in 1 room. I added the node to the laundry room right next to that room. So I am only about 15 feet through 1 wall when testing my phone on that side of the house.

ISSUE:
The issue that started after I enabled AiMesh, is that while browsing the internet, using Instagram, facebook, etc. It will stop loading pages. Or act like I lost internet and not continue to load instagram, facebook, or internet pages. I check and my phone shows full strength wifi. The wifi connection isn't lost. I will then turn off Wifi on my phone to use the cell data and instantly everything works again. I switch back to Wifi and it sometimes works again. But I usually have to walk after from either the master or node to have it connect to the other and it works again. But the issue happens randomly and while on either router's wifi. My wired LAN systems are not affected. I pretty much only use our phones on wifi. Everything else is wired 1Gbe Lan.

The AiMesh is worthless to me if the internet is randomly broken. Great signal and wifi connection doesn't mean anything if the internet route dies randomly.

I haven't been able to find anything in my searches of anyone else having this issue.
 
Not sure what you think aimesh does. Mesh is mostly a wifi repeater function and you are not running it as a repeater you are using it is as AP. So maybe turn off the mesh function and hook the remote unit up as a simple AP. It is still all 1 network.

Now if you think mesh can do roaming that is a myth. The end device not the network controls the roaming. Some system will force the end unit off the network when it thinks there is a better connection and hope the end unit will pick a different connection. The problem is network does not actually know how strong the signals the end unit receives so it maybe see something different.

What maybe happening is the aimesh might be dropping your end device because it thinks there is a better connection.

Roaming seems to be something that marketing people have convinced people they need. Very few people walk around their house while actually using the device, kinda why people walk into traffic staring at their phone. If you set the radio power on your AP and your router (ie turn it down) so there is as little overlap as possible the end device will do a pretty good job of switching by the time you get to the other room.
 

xenon2000

Distinguished
May 2, 2008
83
0
18,640
1
Not sure what you think aimesh does. Mesh is mostly a wifi repeater function and you are not running it as a repeater you are using it is as AP. So maybe turn off the mesh function and hook the remote unit up as a simple AP. It is still all 1 network.

Now if you think mesh can do roaming that is a myth. The end device not the network controls the roaming. Some system will force the end unit off the network when it thinks there is a better connection and hope the end unit will pick a different connection. The problem is network does not actually know how strong the signals the end unit receives so it maybe see something different.

What maybe happening is the aimesh might be dropping your end device because it thinks there is a better connection.

Roaming seems to be something that marketing people have convinced people they need. Very few people walk around their house while actually using the device, kinda why people walk into traffic staring at their phone. If you set the radio power on your AP and your router (ie turn it down) so there is as little overlap as possible the end device will do a pretty good job of switching by the time you get to the other room.
Not sure why AiMesh would use a wired backhaul if it was just a repeater function. Also, the AP mode still says AiMesh repeater mode. So it's likely already an AP since it's using a wired LAN and not a repeater. It doesn't sound like you use AiMesh or the RT68U router in AiMesh mode. And yes, the end device is still doing the switching. And when I am on a wifi call and roaming the house.. that is actively using the wifi while roaming. With the 2nd AP, there is no weak spots in my house. As I mentioned in the first post, the device is not being dropped from the wifi connection. There is some kind of routing issue. It acts like DNS is broken, but randomly.
 
Not sure all the stupid mesh garbage is proprietary. Running a second radio unit as a AP has been done since the very beginning of wifi and is still the gold standard for enterprise installs. None of them use silly mesh systems.

If you can find a way to run the device as only a AP with the mesh turned off it will show if it is the mesh software causing the issue. It might be forcing the end device off the network. This generally reconnect quickly but you will still get application outages. What can happen is the central unit "thinks" the end device should have a better signal on a different radio and forces the connection. The end device though has different signal levels and may reconnect back to the same unit as before. This is extremely hard to see because it happens so fast. It is not fast enough though to protect all applications from seeing it.

Your problem is not no weak spots the problem is too many strong signals overlapping. You must adjust the power on the radios so there is as little overlap as possible but you still get good coverage. Proper radio layout is critical which is why large companies do site survey when they install. Now if some so called "mesh" system had the ability to automatically adjust all the radios for optimum coverage that would be a great feature but only some very high end commercial systems have even partial systems that attempt this.

It can't be a routing or IP or DNS issue. The network is all layer 2 it only cares about mac addresses. Only your main router understands IP everything else is completely transparent from a IP standpoint.

Wifi was never designed for roaming it is a very simple system that looks at signal levels and if they drop too low it looks for a new source . It has no ability to know there is a better signal until it drops. Unlike a cell system where the tower has full control over the radio chip and it can compare what the tower sees and what the phone sees.

Maybe use the brute force method. Cable the second router to a lan port. Leave it set to run as a router with the aimesh off. Turn off the dhcp server and assign a lan IP to something that does not conflict with your main router. You are now using the second router as a AP but all the traffic only uses the wifi radio chip and switch chip so any software on the router CPU should be bypassed.
 

gggplaya

Distinguished
Are you sure you have Aimesh set correctly to use ethernet backhaul? This is not automatic, has to be set to ethernet backhaul manually.

The problem is that Asus tends to beef up the radio's with really good radio transceiver circuits to maximize how much senstivity(range) they can get from their radio's. They are good radios. The problem is, you might still have good signal at the other end of the house and your device is confused and constantly switching access points which will show as a drop.

Some things I would try.
  1. Set the radio power lower on each unit so that you still have a little overlap between access points, but not too much overlap. This is labeled as TX Power Adjustment. You can set it from 0-100%. I would start at 50% and see what it looks like in your house.
  2. Try turning off 2.4ghz temporarily on both access points until you have your radio power set correctly and finish all your experimentation.
  3. Consider a different SSID name for your 5ghz.
 

xenon2000

Distinguished
May 2, 2008
83
0
18,640
1
Are you sure you have Aimesh set correctly to use ethernet backhaul? This is not automatic, has to be set to ethernet backhaul manually.

The problem is that Asus tends to beef up the radio's with really good radio transceiver circuits to maximize how much senstivity(range) they can get from their radio's. They are good radios. The problem is, you might still have good signal at the other end of the house and your device is confused and constantly switching access points which will show as a drop.

Some things I would try.
  1. Set the radio power lower on each unit so that you still have a little overlap between access points, but not too much overlap. This is labeled as TX Power Adjustment. You can set it from 0-100%. I would start at 50% and see what it looks like in your house.
  2. Try turning off 2.4ghz temporarily on both access points until you have your radio power set correctly and finish all your experimentation.
  3. Consider a different SSID name for your 5ghz.
Yes, wired backhaul is setup correctly. Not sure how you could mess this up as there is only 1 setting. The setting is labeled "Ethernet Backhaul mode" and it's either on or off. It's on. And then when you look at the Topology status screen is says Uplink = Ethernet, and says Backhaul = Ethernet. And then Fronthaul = Ethernet, Wireless 2.4, and Wireless 5 Ghz. SSID is a different name for 2.4 and 5 Ghz networks. As well as different from guest networks.

Silly that radio power wouldn't be automatically set. I don't see any radio power settings. I will google to see if it's hidden somewhere.
 

xenon2000

Distinguished
May 2, 2008
83
0
18,640
1
It's listed as tx power adjustment on my 86u.
I just found it under Wireless -> Professional -> Tx power adjustust. As a slider listing names for power. lol. From "Power saving" to "Performance". But while I have 2 APs, Master and Node. I only see 1 setting so I imgine it affects both routers with the same setting.
 
Nov 9, 2021
1
0
10
0
I've have little luck with getting AiMesh to work reliably with my setup. Although slightly different compared to yours, i.e. I have DSL-AC68U (Main) + RT-AC68U (Mesh node), AiMesh would drop offline from time to time, and only a restart would fix the issue. Both my routers are running Merlin software (updated to the latest), tried both Ethernet and Wireless backhaul but the same issue! Funnily enough, running the RT-ACU68U in Access Point mode proved to be way more stable (but you'll need to have Ethernet backhaul) compared to AiMesh mode, and it seems to be a common theme when you read other forums where users have the same issue. I dunno what it is, maybe AiMesh isn't quite up to it, so for me personally, I've given up on it and just used Access Point mode. FYI, routers setup with the same SSID's.
 
The main problem with any mesh system is they try to do stuff like roaming etc. They have no ability to actually know the signal levels the end device has and are making predictions based on the signal levels the mesh nodes see. This causes all kinds of instability in some cases. There really is no fix unless they completely redo the way wifi functions so it is more like a cell phone network where the network is in full control of the end devices.

Maybe wifi6e will help. There is much more bandwidth on the 6g radio band. This should allow people to not overlap each others signals as much. This might allow us to use just a single router for coverage again. Wifi will work very well with a fairly weak signal if there is not a lot of interfering signals. Most wifi problems today are all related to have too much radio signals. All these mesh systems people are putting are actually making the problem much worse. I think it is a scam by manufactures. The more mesh systems that are sold the more you need to buy mesh systems to overpower the interference caused by all the mesh systems.
 

ASK THE COMMUNITY

TRENDING THREADS