Question ASUS B450-F Gaming fails to boot when too many USB devices present/too many storage devices

cGDeadly

Reputable
Jul 10, 2016
6
0
4,510
0
I have an ASUS B450-F Gaming motherboard and whenever I: attach more than two storage devices, or a USB device of any kind it stops my computer from booting. The fans spin up and the bios splash screen shows and it will just continue to do that until I remove enough devices.

For example: It has 2 M.2 slots that are both populated, but for some reason if I put the NVMe drive in the top slot and then the SATA drive the bottom one, it fails to recognize any other storage devices (I tried hooking up one of my normal 2.5" SSDs and it failed to recognize it too. Tried different SATA cables and PSU, nothing.

Anyways, when I moved the NVMe drive to the bottom slot and the SATA to the top slot, it booted up perfect and recognized each device. However, when I plugged in the normal SATA SSD, it returned to the boot loop.

For now I have resorted to removing the third drive completely. Anyways, sometimes if I put in a flash drive , or even just a micro-usb cable, it will return to that state of constantly restarting until I remove enough devices.

I hope I am able to solve this, I would appreciate some help!

Specs:
MOBO: ASUS B450-F Gaming
CPU: Ryzen 5 3600 w stock cooler
PSU EVGA Supernova 750W
Drive 1: Intel SSD 600p Series 1TB M.2
Drive 2: WD 1TB SSD DATA M.2
Drive 3: SanDisk 250GB SATA SSD
GPU1 : RTX 2070 Super
GPU2: AMD RX 580
RAM: 16GB (8x2) Corsair Vengeance
 

alexbirdie

Proper
Feb 20, 2020
170
29
140
6
Both MB-Powersupply-cables connected (not only the big 24-pin, but the little 8-pin)?

Board has 2 m2-slots:

1 x M.2 Socket 3 with M key, type 2242/2260/2280 storage devices support (SATA & PCIE 3.0 x 4 mode)
1 x M.2 Socket 3 with M key, type 2242/2260/2280/22110 storage devices support (PCIE 3.0 x 4 mode)

That means, one of them can be not used for SATA-SSD.

And if the SATA-M2-slot is used( for SATA-NVME):

*3 When the M.2_1 Socket 3 is operating in SATA or PCIE mode, SATA6G_5/6 ports will be disabled.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS