[SOLVED] ASUS B450 F no sata ports detected, no drives showing up?

islandtriumph

Prominent
Jan 6, 2019
7
0
520
1
Hi Everyone,

So here is the breakdown, I am going to keep this as simple as possible. I am helping out a friend with a build that I did a while ago and essentially is now a new build.
The first build I did for him just randomly crapped out after two years, literally would not boot. Still not sure what went wrong beside somehow a bent pin in the cpu (makes no sense) anyway, now it has an ASUS B450 F, Ryzen 5 3600, and some DDR4 3000 swapped out now.

PROBLEM
He had 1 SSD and one HDD, the windows being installed on the SSD of course. That is still being used and this is where the problem lies. We cannot even see the drives in BIOS at all, a thumb drive can be seen in the boot, to get us to the windows installation tool.
Anyway, no SATA connections can be found whatsoever in the configuration menu.

TROUBLESHOOTING

BIOS updated to version 3003
We thought maybe the drives were fried from the previous build, so we grabbed an HDD from an older laptop of his. Still didn't show up.
We exchanged the mobo for a new one in case the SATA ports were dead
We tried new SATA cables and power cables to the SSD and HDD
Tried just the SSD and just the HDD separately
Made sure that AHCI was enabled for the SSD
Made sure we tried both legacy and UEFI

Future trouble shooting
Get new SSD and/or HDD
Figure out if we can update SATA controller driver, while we are in the windows installation tool using "find driver"
See if we can do a "repair installation" so it pulls from the drives, saw on another thread that this may be possible (doubt it if bios doesn't even pick up the sata ports)

picture of possible solution from another thread

What do yall think?

Thank you
 
Last edited:

islandtriumph

Prominent
Jan 6, 2019
7
0
520
1
update the bios?
so you didn't install windows on this build, but it was from another pc?
Windows hasn't been installed on this build no. The drives came from the previous build. The ssd has the windows from before but of course the drives aren't seen at all so we can't do a repair install that would pull from it. We just can't get the dang drives to show up.
 

islandtriumph

Prominent
Jan 6, 2019
7
0
520
1
it might not be able to boot from it, if it from an old system.
does it show up as a disk drive?
No, none of the sata ports even show up under boot configuration. Tried a new ssd under all the ports and nothing. Something is off if two of the b450f mobo are doing the same thing. But yeah did a lot of troubleshooting and I'm all out of ideas.
 

ASK THE COMMUNITY

TRENDING THREADS