Question Asus B460-PLUS won't post after enabling CSM in bios

Sep 29, 2020
1
0
10
0
Specs:
Mobo: Asus Prime B460-PLUS
CPU:i3-10100
GPU: Asus 1060 3gb
HDD: Some old 1tb Seagate

So I recently upgraded my Mobo and cpu, the bios loaded fine at first but didn't recognize my HDD as a suitable boot device. I made sure it wasnt on RAID and tried restarting my pc, still didn't show. After which I tried turning on CSM in the boot tab and restarted. This time the bios just didn't post at all, computer turned on fine everything is running and it posts if I reset CMOS. I've also tried turning on CSM with absolutely no storage device hooked up and it still didn't post. I'm completely lost here.

Update1: after enabling CSM it appears that my display port cable hooked up to my gpu was the culprit, however CSM is completely grayed out now and still no boot device shows. Did my HDD just randomly die during the upgrade?
 
Last edited:

Colif

Win 10 Master
Moderator
When you swap motherboard/CPU it generally helps to reinstall windows or you can run into problems... like this. It could be the way the bios boots off the hdd is different now. IT might use the windows boot manager and since it has no links to the drive its looking for, it won't work.

Which version of windows are you on? If win 10, do you have an installer?
On another PC, download the Windows 10 media creation tool and use it to make a win 10 installer on USB

I would suggest trying a clean install. If there is anything on C you want to save, try this
change boot order so USB is first, hdd second
boot from installer
on screen after languages, choose repair this pc, not install.
choose troubleshoot
choose advanced
choose command prompt
type notepad and press enter
in notepad, select file>open
Use file explorer to copy any files you need to save to USB or hdd

I dislike how little Asus show in the manuals about the bios on B boards. I can't even tell if you have Boot override in Save & Exit screen. It would mean you didn't need to change boot order like above.
 

ASK THE COMMUNITY

TRENDING THREADS