Question Asus Crosshair V Formula Not Booting

Feb 24, 2021
1
0
10
0
Hi guys,

I have an Asus Crosshair V Formula (Not the Z version) that does not want to start up at all. It has been lying in storage for the past few years but I want to build a gaming rig out of it because this board cost me a lot of money a few years ago!

What happens is when I turn on the power supply the OC, Power and Reset buttons light up brightly but also the HD led (Next to SATA Ports) and Go led (Next to the GO button at the top right) turn on though very faintly. When I press the power button, nothing happens. Like I didn't even press it at all... None of the leds for RAM, CPU, VGA and Device light up either.

I have tried 2 different PSUs (300w out of an old Packard Bell and a Corsair CX650) and i know the Corsair one works as I use it in my daily.
I have tried 1 RAM stick in, RAM out and in all 4 slots with no luck
I have tried clearing CMOS, re-seating CPU with and without graphics card, turning of from the case power button, with and without a Hard Drive plugged in.


Specs are-
AMD Athlon ii x2 B24
The PSU that I stated above
1 stick of 2GB HP RAM
ASUS EAH5670 (I just have lying around)

I am stumped at this point as I think I have tried everything I can think of but I don't know if I am missing something? I am thinking at this point the board is dead and that's that but I don't want that to be the case!

Any help will be greatly appreciated

Thanks
 

ASK THE COMMUNITY

TRENDING THREADS