Asus DRW-24b1st Not Working

Status
Not open for further replies.

eschooche

Distinguished
Jan 13, 2012
8
0
18,510
Today I built a new computer with an Asus Drw-24b1st. It worked great for installing Windows, and I got everything up and running, but I've run into problems trying to get anything else to run off of it. The drive itself is recognized by Windows. I can find it in the device manager, etc. However, anytime I insert media of any type, it spins and the green light comes on like it is supposed to, but I can't pull open the files on Windows. Now, I don't have the latest firmware, but I can't install it off the the DVD because of this problem. I tried getting it off of their website, but when I tried to open one of the files, it said I had the wrong version (32/64 bit) of windows. I'm sure I downloaded Windows 7 64 bit drivers, and I'm sure I'm running windows 7 64 bit. The other file says that it is meant for a DRW-24b1st and I have a DREW-24b1st_a 1.04.

Any ideas?
 
Solution
You shouldn't need to update the FW just to read and write files. Try moving the SATA connector to another SATA port and see if that helps.
Status
Not open for further replies.