[SOLVED] Asus Essence STX II - Power Connector (4-pin Molex)

Oct 1, 2020
2
0
10
0
Hello,

I have a pretty weird question: Is there a way for me to test if the Asus Essence STX II is properly connected to my power supply? For some reason that 4-pin Molex slot is incredibly hard to connect with the female pin. I don't know why, but it seems to take unbelievable amounts of force and I thus stopped half-way, scared of damaging something or literally breaking the card. Now I am not sure if the pin is already properly connected, it did not go all the way in. So here I am wondering if there is a way for me to test that. I have downloaded the driver for the card and played around with some settings, but I would like to somehow confirm if everything is fine before actually plugging my headphones in.

Also: Is that pin supposed to be so [redacted] hard to get onto? I am 99.99% sure that I have the right female connector from my power supply, I checked various times with google-searches and it seems to align perfectly - at least in theory. But it seems unlikely for it be that hard to get on. Although I did find some results that seemed to struggle with it as well.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
It's usual to require force when plugging in the 4pin connector to the sound card. I've had similar experience. It's worse when you have to deal with a PSU that has a connector that doesn't want to cooperate.
 

Lutfij

Titan
Moderator
It's usual to require force when plugging in the 4pin connector to the sound card. I've had similar experience. It's worse when you have to deal with a PSU that has a connector that doesn't want to cooperate.
 
Oct 1, 2020
2
0
10
0
Alright then, thank you for your reply! I did apply some more force, some waggling left and right and I think it is now pretty much all the way in. Seems to work fine!
 

ASK THE COMMUNITY

TRENDING THREADS