Question Asus H610m-k D4 black screen no post after bios update

Mar 20, 2023
Hi. I purchased an Asus H610m-k D4 and I3 12100f paired with 16gb of corsair vengeance LPX ram and AMD R9 260x. System worked fine until i updated bios which went successfully but on restart the pc wont post. The power LED flashes quickly (indicating no ram) followed by medium (indicating no gpu) and then reboots. I thought i had bricked it so i got a cheap Asus H610m-k D4 and like a fool i updated the bios but to a different release.. same issue. i called Asus help line and they could not help and said to send the boards back to suppliers so I sent the boards back to the 2 suppliers thinking it may be a bios chip fault but they both sent back saying that it worked fine. I then changed the ram to hyperX and no change.. changed the GPU with an R7 240 and then an RX 6700xt red devil.. still no change.. i then used generic crucial 2133mhz and then 2666mhz but still nothing.. Tried with corsair 650w supply and EVGA 600w too and Ive done the cmos clear with battery and jumper.. single ram.. no gpu ect but nothing works. Lastly i called one of the suppliers and asked what they used to test the board and they said an I5 and RTX 30 series card.. All ram is listed in the QVL and i know they work as tested on friends system and the corsair worked before bios updates. All Gpu's are working fine.

Both boards shipped with PRIME H610M-K D4 BIOS 1402 dated 2022/04/02
The K version board i first updated the microcode, the Intel ME to specified release and then the bios to PRIME H610M-K D4 BIOS 1620 as it is needed for 13th gen support
The A version i only updated to PRIME H610M-K D4 BIOS ver 1603 believing that skipping this version on my other board had caused the issue
Both were updated with an 8gb usb formatted to fat 32 and updated in the bios with Asus software. Both reported as successful and both give me the same error now.
But the supplier says they had both boards posting and working correctly which is why im confused.. and stuck..
Any thoughts??

Available System Items

Asus H610m-k D4 / Asus H610m-a D4
Intel I3 2100f - stock cooler
windows 10 last updated around december 2022
2x 16gb corsair vengeance LPX
2x 16gb Hyper X
2x 8gb Crucial generic 2666mhz
2x 4gb Crucial generic 2133mhz
240gb Seagate ssd
Corsiar 650w / EVGA 600w
Mar 20, 2023
Thanks but ive solved it.. the long way round..
i got to borrow a 1050ti and the board does post with that. After searching around i then borrowed a celeron G6900 because it has an IGPU, installed it and connected board via this igpu.. this gave me a flashing on and off bios screen. so i connected an old monitor via the VGA connector on the motherboard and this worked.. posting to bios with no issues. Then i left the IGPU connected but put the AMD GPU back in and restated. The took a while to boot up and diplayed a message saying. 'The VGA card is not supported by uefi driver' and stated it had made changes to the bios. I did a quick google search and went into the bios and chanced settings from windows uefi to used legacy support.. So lastly i reconnected the AMD card to original monitor via hdmi and its all good. Replaced ram with my original ram. restarted.. also good.. and lastly replaced Celeron with the I3 12100f and its all good. So the problem seems to have stemmed from the bios update making AMD cards unsupported.. while Nvidia cards and the Igpu's on Intels cpu's are
Strange but solved.
  • Like
Reactions: Aeacus