Question Asus Laptop not charging while plugged in


Mar 11, 2016
My laptop is an Asus Q504UA 2-in-1 touchscreen laptop.

Suddenly the laptop cannot be charged.

I have tried to put it in different outlets and with different adapters and it made no difference. Then I installed a new battery which allowed me to turn on the laptop for a short time, but it would not charge.

While the laptop was on and plugged in, it recognized it was plugged in with a few indicators. First the orange light was on, indicating that it was plugged in and it had less than 95% charge. When I plugged it in the screen would become brighter. The icon on the bottom right showed that the laptop was plugged in, it also claimed that the battery was charging.

This is true for both adapters I used. On top of showing that it is charging, it gives an estimate on how long it'll take to be fully charged.

However, that number increases as the battery is drained.

I have a few guesses to what the problem could be but I'm unsure.

As for software, I've only been able to access the laptop itself for a short time as it's slow to load due to the many shut downs from the battery dying. I followed the Asus steps for reinstalling the battery driver and that made no difference.

I've not tried to update bios or tried to update windows as those processes would take longer than the battery has energy still in it to complete those processeses.