Question Asus laptop only work by constantly swapping RAM from one slot to another

Sep 11, 2020
2
0
10
0
My asus laptop turns on with a black screen unless i move the RAM from one slot to another every time before powering up.

Tried hard reset, different RAM modules, removing hard drive, trying a different power supply, plugging in VGA monitor and nothing worked so far.
Its not a power thing (probably), it always turns on but with a black screen, the peripherals work (mouse, keyboard lights up). Sometimes it runs
for a few seconds with loud fan and shuts down, most times it stays on with black screen.

I made sure the RAM is compatible, it should work! sometimes it does work randomly.

Laptop Model K45A https://www.asus.com/Laptops/K45A/

Any ideas what may be the problem?
 
Last edited:
Sep 11, 2020
2
0
10
0
i tested other RAM modules on the same laptop and they are working and are compatible, thats why i said that it should work, the problem is not the RAM stick.
tried reseting the bios and it did not work, i can't get the damn thing open to remove the CMOS battery because of a stripped screw, and i'm afraid to perform a bios update,
i have no idea why this laptop is behaving like that and performing a bios update seems risky since i can't predict if its going to turn off in the middle.
the laptop has the oldest version of bios available for it, maybe updating will solve the issue but if it gets corrupted its over.

the laptop works normal if it stays on all the time or if i restart it, but if i turn off or put it in sleep mode the screen goes black again and does not come back.

here is what happens from the start:

Power supply in, turn on, loud and fast spinning fan with black screen, hold power button to turn off, turn on again, normal speed fan and black screen, turn off, power supply out and repeat. nothing changes.

BUT if i move the RAM from slot 1 to slot 2:

Power supply in, turn on, loud and fast spinning fan with black screen, hold power button to turn off, turn on again, normal speed fan and normal screen, Windows working normaly, no problem, i can restart and it comes back normal again, i can turn it off and on again two or three times, but if i turn it off after that or put it in sleep mode it never comes back and the black screen returns, then i will have to move the RAM from slot 2 to slot 1 again, and the cycle repeats.
 
Last edited:

ASK THE COMMUNITY