ASUS M5A97 R2.0 - Won't recognize hard drives

SuperiorRedneck

Reputable
Aug 1, 2015
18
0
4,510
0
So I've had my current setup for going on 2 and a half years now. It's my first build, I've leaned alot there have been minor hickups here and there but for the most part it's been a pretty solid machine...until recently. It started by having weird issues where I'd put it in sleep mode then it would take forever to get there but then it would start up almost instantly. Also it wouldn't turn the display off after 15 minutes. Not sure if that is relevant, but the issue I'm having now is it will out of no where, restart and then show the ASUS boot screen, then go to a screen that says "Reboot and select a proper boot device or insert boot media in selected boot device and press a key." Sometimes I can restart it repetitively and it will boot but usually it's short lived. When it does this, I've swapped an SSD in to see if it was my hard drive and I get the same result which leaves me to believe its the motherboard. Anyone had this happen to them? Any help would be greatly appreciated. Thanks!
 

krzyimprt

Honorable
Mar 25, 2013
1,210
0
12,660
285


Did you try setting your HDD priority to the drive that has windows on it? Try a different sata port?
 

SuperiorRedneck

Reputable
Aug 1, 2015
18
0
4,510
0


Yes, I've made sure the priority is set to HDD and I've tried different ports.
 

krzyimprt

Honorable
Mar 25, 2013
1,210
0
12,660
285


If no drives are being detected in the bios then your sata controller most likely died.
 

SuperiorRedneck

Reputable
Aug 1, 2015
18
0
4,510
0


So is that something replaceable or does that mean I need a new motherboard?
 

krzyimprt

Honorable
Mar 25, 2013
1,210
0
12,660
285


You'll most likely need a new motherboard. I highly doubt resetting the CMOS will fix it.
 

SuperiorRedneck

Reputable
Aug 1, 2015
18
0
4,510
0


I'll try resetting the CMOS because it can't hurt but I probably wont be that lucky. Is it very common for the sata controller to give it up or is this a 1 in a million thing?
 

krzyimprt

Honorable
Mar 25, 2013
1,210
0
12,660
285


Unplug the power cord and hold the power button for a good 30 seconds to completely drain power to the system, It will reinitialize everything from a cold boot. If not I'd look into replacing the mobo.
 

wsjchay

Prominent
Nov 22, 2017
1
0
510
0


If you go to the Asus website it will give you a list of certain SSD's that are compatible with the M5A97 LE R2.0 motherboard. Just choose your OS accordingly then scroll down to the 'Qualified Vendors List' and it should tell you. Hope this helps!
 

Similar threads