Question Asus Maximus Vii Ranger Problem

Hazem_4

Reputable
Jul 25, 2016
3
0
4,510
0
I built my PC about 5 or 6 years ago and all this time it was working properly until about 6 months when I started getting A2 error code on my motherboard. I searched google and I found out that it is a storage issue and tried to disconnect each storage device to check where is problem then both to try and access the BIOS. When disconnecting both devices, I get error code 00 on my motherboard. I tried to do everything I found online nothing worked except performing a USB BIOS flashback. After that, the PC started working for a week or so, until it was shutdown. Now the problem is there again and I tried to do a BIOS flashback and it still didn't work and now I am thinking that maybe the mobo got fried when the power went a few months earlier. Is my mobo done? and If not is there anything else I can try to get my PC back up and running?

Thank You

Spec List :

ASUS Maximus Vii Ranger
Intel Core i5-4690 Processor (With Corsair Hydro Series High Performance Liquid CPU Cooler H60 )
Corsair Vengeance Pro Series 8GB (2 x 4GB) DDR3 DRAM 2400MHz
Samsung SSD 840 EVO Series 120GB Basic-Edition (Boot Drive)
Seagate Barracuda ST1000DM003 1TB
EVGA GeForce GTX760 SuperClocked w/EVGA ACX Cooler
EVGA SuperNOVA 750G2 80PLUS Gold Certified
 

ASK THE COMMUNITY

TRENDING THREADS