Aug 7, 2011
So I've been working on this all day. I am extremely frustrated as I've been waiting in anticipation for this damn PC for 2 weeks thanks to UPS.

Mobo: Asus P8P67 B3
CPU: Intel 2500k
RAM: 2x4GB G.Skill Ripjaw (DDR3 12400)
PSU: Corsair tx650w
HDD: 500gb WD Black
Stock cooler, arctic thermal paste

Basically the DRAM_LED is red. I've went through about the first 30 topics that come up on google and none of them have solved my problem. I have tried old ddr that is ddr3 12400 2gb a stick, one in each slot. I have tried resetting CMOS w/ the jumper + the battery. I also tried taking out the whole motherboard, connecting only the cpu fan, the atx psu and the front panel power pin and even then the led turns red. Then with only those things connected I go through all 4 of my RAM sticks through all 4 slots and each time it's red. If I hold the memok button the pc restarts and the led blinks. The fans all light up and spin and the most obvious issue of this post is: no post, no video. Also I have no system speaker installed and my chassis does not have one either. Need more info just ask....seems like something I would just RMA at this point to be honest. :(