Asus p5b and Kworld/Peak Tuner show only as USB Hub?


Oct 7, 2008
Hi Guys,

I've posted this in the asus forum - as i'm sure this is a problem with the mother board.

I have just purchased a Kworld DVB-T PC160 tuner card - i've found out this is also sold as a Peak DVB-T PCI tuner card (221544agpk)

I have a Asus p5b mother board - with the lastest bios version. Windows XP Service Pack 3, all up-to-date.

Basically, this tuner card works in all other computers i've tried -- but not in my machine.

When installing correctly, on another machine, it installs the following:

VIA USB Enhanced Host Controller, Via Rev 5 or Later USB Universal Host Controller, and 2 USB Root Hubs -- and then finally installs DVB-T 2 and AF9015 BDA device. The tuner then works fine.

On my asus p5b machine, it only gets as far as installing the usb hubs, not never the DVB-T 2 and AF9015 BDA device. So in device manager i have the usb hubs, but not the tuner.

I "think" the problem may be that the mother board is not allowing usb2 on the pci usb hub in the tuner.

The pci port works - as i've tried a pci sound card and it works fine.

I have bios set to hi-speed usb.

Many thanks for reading! :) I have asked this after 3 days of trying to fix the problem myself! :cry:

(Somone has the same problem HERE if he explains it better then me. Another person with the same problem HERE)



Dec 3, 2011

I have exactly the same problem on a dell optiplex 780. Did you ever resolve? Its gota be motherboard related , changed pci slots, dont have any irq/dma options in bios, updated bios to latest A10

I've tried XPSP3 and WIN7PRo with the same problem. I get the 2 VIA Host Controllers and thats it, no DVB-T.

peak dvb-t 221544AGPK AF9015 BDA

Any help appreciated