Question Asus P5Q Deluxe Little to No Internet Win7 install

Wraith_3

Reputable
Jul 28, 2017
27
0
4,530
0
I had my old PC as a backup and a while back damaged the BFG Tech nforce motherboard (built 2007-ish) and bought a used Asus P5Q motherboard to replace it. I just got around to messing with it and it seems to work fine until I installed Windows 7 (on the way to a Win10 upgrade). I get little to no Internet. Most sites look like they don't load correctly or won't load and say there's some certificate problem. Also when I try to activate Windows or run Windows update I get an error that Google says is tied to not being able to communicate with the server. I can't even download Firefox. I'm using a TP Link TL-WN722N wireless adapter, which I know works. I do not have the original driver CD, though I did install the ones off Asus' site, which would be the Intel chipset drivers and Ethernet controller drivers. I've never had this many problems installing Windows or getting wireless. Any ideas?
 

JWNoctis

Notable
Jun 9, 2021
410
93
990
56
I thought Windows 7 is long out of support - I don't know if it's still possible to get patches through Windows Update, but that's pretty doubtful now.

Old versions of Windows and IE had no support for current versions of TLS protocols. Grossly wrong system time could also cause similar issues. It's probably not a driver problem.

Solution: Install Windows 10 directly, but good luck with the drivers.
 

Wraith_3

Reputable
Jul 28, 2017
27
0
4,530
0
I don't think I can install Windows 10 directly because I was only using the upgrade and never made a clean install flash drive to install. I did make sure the system time was correct, that would at least sync with Microsoft. So if I have no Internet I can't install Windows 10. If worse comes to worst, I'll just have to let it die and get a cheap PC for my backup.
 

ASK THE COMMUNITY

TRENDING THREADS