Asus P7P55D Power Problem!!


Aug 1, 2012
hi everyone.
I've bought Asus P7P55D working fine for me untill today I'm having a strange issue regarding booting up my system. When I power on the MB. CPU_LED light blinks for less than a second and goes off , the whole system goes off and on again and again.
What I've done , removed everything on MB except power connectors 24pin and 8Pin.
tried clearing BIOS. but no result , also try to bootup with MemOk but still same issue.
Also checked whether I seated the CPU in place. No bent pins, socket also not damaged.
But when I remove the 8pin on top of MB the system gets on with steady red light of CPU.
I then tried to remove the CPU and power on the MB.. Still the same !!! .

Seems to me like MB doesn't even detecting the CPU at first place. Or maybe some other problem.

I thought for a sec it might be a PSU probelm so I've changed my PSU from Cooler Master GX-650W to brand new Corsair TX950 950W .. still the same.

Is it the faulty Motherboard ? or something else would work ?
Help needed !!


Jul 1, 2012
Had you pressed the motherboard against the back of the computer? If so maybe you had not put all the motherboard standoff screws and so it may be shorting out because its touching the metal part. If that's not the case try getting a flashlight and with the removed cpu look at the socket and see if there is any pins stuck inside or any debris. If there is nothing like that then return the motherboard but take a look at the cpu pins again from various perspectives, when I bought my cpu it looked like there were no bent pins but from looking at it at eye level some were bent.


Nov 28, 2010
I have that MB and a Cool master PS also and have had that same power up problem shortly after i built the system.

In my case it always worked after a few (2 or more) reboots. It seemed as though it would work again after the following two things i did.
If i unplugged the power from the PS and then after a minute or so plug it back in and boot up. (It was like the PS would go into overload and not power up)
The other things i did was use the Mem OK button or change the BIOS setting back to normal (auto), as i was trying out Over Clocking and then had issues on reboot. I had installed the OC utils from ASUS and i think they were making changes that would hose up the BIOS and cause the reboot hang.

This issue has not happen on my PC now for about over 2.5 years, it was only happening in the first few months after i built the PC.