Question ASUS P8 H61-I RM SI MOTHERBOARD ISSUE

matthews39

Honorable
Nov 20, 2013
78
0
10,630
0
Hi all just built a computer with this board using i5 3570k but i am getting no display. Ive removed ram and swapped them over, changed from my working graphics card to vga, took mobo battery out, checked all power connectors. Theres power to the board and the graphics card so im left with the assumption that the board needs a bios update. So my question is can i flash the bios on that mobo as im hearing you cant with RM version and can i do it through USB flash drive and no display. My other option is to put an i5 2500k in to boot it up and then update the bios after. If the i5 2500k is supported? .
 

matthews39

Honorable
Nov 20, 2013
78
0
10,630
0
Hi, What are the last 4 digits on a thin sticker on the board?
Hi I will check in a min. I've put my daughters 2500k in my motherboard and it run and I put my 3570k in her motherboard and it worked. So I decided to just swap motherboards but when i put her motherboard and my 3570k it didnt work again ... frustrating
 

matthews39

Honorable
Nov 20, 2013
78
0
10,630
0
Now I'm confused I plugged in the VGA and it comes on so is my card not compatible with my daughters motherboard. Card is r9 280x and motherboard is intel as g14064-207
 

matthews39

Honorable
Nov 20, 2013
78
0
10,630
0
Updating the BIOS on your board might be a solution.
Right it looks like the intel board cannot take the graphics card, i put my daughters g force 660 ti in and it worked. So i tried updated the ASUS P8 H61 I RM/ SI board but i cant as its the RM version. I tried download a couple of ROMS and installing through EZ FLASH tool on the bios but it wont work.
 
You can try buying a BIOS chip from ebay for ASUS P8 H61 I and replacing the board's one, or using afudos to flash a ASUS P8 H61 I BIOS version on the chip on board. Unfortunately, no backup options for afudos, if not working. With the BIOS chip, you can replace it with the original one.
 

matthews39

Honorable
Nov 20, 2013
78
0
10,630
0
Hi all,

I have just installed a I5 3570K in a GA-B75M-D3V but it kept saying no display, So i swapped out my graphics card which is R9 280X for a ge force 660ti and it works fine. Is the card not being compatible with the board or is it lack of power?? My card works in my old AMD board M5 A 78L LE
 

ASK THE COMMUNITY

TRENDING THREADS