Aug 4, 2011
This morning my new computer parts arrived including:
Asus P8P67 Deluxe motherboard
Ultra x4 850w psu
Corsair vengeance 8gb ddr3 ram
Corsair H80 water cooling system
Intel Core i7-2600K BX80623I72600K Unlocked Processor
note: i am using a old graphic card (gtx 260 ) along with a old hd and dvd drive.

Once i put the entire machine together and tried booting the pc nothing happened other than the 'cpu_led' being contently red no sounds from the bios or anything like that. After playing around with it redoing the wiring all over again the exact same problem occured. i took everyrthing out of the case and placed the mobo on a flat surface and tried powering it on with just the 24 pin connector this time the red cpu led blinked and everything shut down. when having the 24 and 8 pin power connected it was the same story. Soon after i reassembled the computer just with 1 stick and connected a few fans along with the corsair water cooling. The cpu cooler didnt work whatsoever but the fans plugged into the mobo did. Now the cpu led would blink red once fans would power on for about 4 secs power off and power on again for another 4 secs after that nothing happens. I called asus they had nothing else to say put to try 1 stick of ram so i did and it was the same story. they think its a faulty cpu socket in the board. What do you guys think please help.