Asus p8z68-v pro not detecting hard drive

Faize

Distinguished
Dec 29, 2011
8
0
18,510
Putting together my first custom built PC.
i5 2500k
asus p8z68-v pro gen3
8gb gskill ripjaw
WD Caviar Blue 320gb.

Everything starts up just fine but the mobo seems to not recognize the hard drive. The hard drive is detected in bios and can also be seen when you choose the boot section.

When I start it up it says "no hard disk detected" and just restarts.

Also the LED that says boot device on the mobo is glowing so something is wrong.
 
Solution
You probably didn't successfully install the OS with that boot order. As far as I'm concerned, you should set the boot order as DVD-ROM followed by Hard Disk and then reinstall the OS. If WIndows 7, also make sure that the Intel SATA controller is set to AHCI. You can use F8 (boot device list) at POST to select the boot device, but that won't help if the OS isn't installed properly. To disable the Marvell controller in the BIOS, I presume that you simply set it to "Disabled".

Faize

Distinguished
Dec 29, 2011
8
0
18,510
I have the SATA and the power cable plugged in. How do you get to disk management if you can't start windows? Can only get into bios without my computer restarting.
 

Faize

Distinguished
Dec 29, 2011
8
0
18,510
I tried to install windows on the harddrive since I can book from my dvdrom and it says that it is on there when I try to repair from the windows DVD. I have the HD plugged into the SATA3G_3 connector. Should I plug it into the Marvell serial ata 6.0 GB/s connector? Maybe the wrong SATA connector? The HD is only a 3gb/s hard drive though.
 

Faize

Distinguished
Dec 29, 2011
8
0
18,510
I built the computer last night, installed windows, when I try to start up the computer it says "no hard disk detected" and instantly restarts. I can however get into bios and it shows up under the boot devices.
 

Faize

Distinguished
Dec 29, 2011
8
0
18,510
I have the boot order as the hard drive and then the DVDrom. Once I get home from work I will try disabling the Marvell controller. F8 at POST? Such a when it is starting up and hit the Fkey to select either the Hard Drive, DVD, or go to set up? Also, how do you disable Marvell in bios?
 
You probably didn't successfully install the OS with that boot order. As far as I'm concerned, you should set the boot order as DVD-ROM followed by Hard Disk and then reinstall the OS. If WIndows 7, also make sure that the Intel SATA controller is set to AHCI. You can use F8 (boot device list) at POST to select the boot device, but that won't help if the OS isn't installed properly. To disable the Marvell controller in the BIOS, I presume that you simply set it to "Disabled".
 
Solution