[SOLVED] Asus Prime A320M-K with Crucial CB8GU2400 -- No POST, no display, not working.

Aug 27, 2020
2
0
10
0
I have ordered CRUCIAL memory with model number CT8G4DFS824A. I have been ordering parts online for over 2 months now. (I prefer to order slowly and one by one. :)
Crucial 8GB DDR4 1.2v 2400Mhz CL17 UDIMM RAM Memory Module for Desktop
But when the order arrived it was with model "CB8GU2400". I don't know why sellers don't pay attention to the details. I tried to find difference in both of these online but could not find any.
So why not give it a try. I inserted "CB8GU2400" memory and switched on the power. System started with a long beep and two short beeps but with no post or display. I checked the FAQ's section and found that this particular beep code is because system is not reading memory. Now I am wondering is this the only sole reason or there can be more than that. I ordered for the replacement.
 
I have ordered CRUCIAL memory with model number CT8G4DFS824A. I have been ordering parts online for over 2 months now. (I prefer to order slowly and one by one. :)
Crucial 8GB DDR4 1.2v 2400Mhz CL17 UDIMM RAM Memory Module for Desktop
But when the order arrived it was with model "CB8GU2400". I don't know why sellers don't pay attention to the details. I tried to find difference in both of these online but could not find any.
So why not give it a try. I inserted "CB8GU2400" memory and switched on the power. System started with a long beep and two short beeps but with no post or display. I checked the FAQ's section and found that this particular beep code is because system is not reading memory. Now I am wondering is this the only sole reason or there can be more than that. I ordered for the replacement.
Which CPU ? It may need BIOS update.
 

ASK THE COMMUNITY

TRENDING THREADS