Question ASUS Prime X370-Pro Bios update issue

02ebz06

Honorable
Feb 20, 2015
4
0
10,510
0
As subject says, having problem trying to upgrade an ASUS Prime X370-Pro Bios.

Background:
I have three ASUS Prime X370-Pro MB's, two in Servers, one in my PC, all have same firmware version, same Ryzen 5 CPU's and 16GB Ram.
Was going down a rabbit hole trying resolve a different problem (which I solved) and one suggestion was to upgrade to latest bios.
So, I found a 7/2020 bios for my boards and downloaded the zip file.
Unzipped it, and copied the the CAP file the a USB stick formatted to FAT32.
Put it in front USB port on my PC, and rebooted my PC and entered the bios.
Started EZ-FLash and upgraded the firmware with no issue.

Now the problem:
Took same stick and did same thing on my backup server and got the "selected bios is not a proper bios file " when I clicked on the read file.

Troubleshooting steps:
Renamed file to 8.3 format (ASUS5601.CAP) per some forum suggestions. No help.
Reformatted the USB stick with full format to FAT 32. No help.
Extracted the CAP file straight to the USB stick per some forum suggestions. No help.
Tried different USB port. No help.
Tried different USB stick. No help.
Tried downloading staight from Internet via DHCP no help.
Just dawned on me that I may have check my router.
Don't think DHCP is disabled, I just don't use it.
I use fixed addresses for everything on my network. Like to know what's on my network.
Also just realized I have a NIC on the MB and and a pcie NIC with two ports.
I do NIC bonding on the servers, but not on PC.
Might try removing the card if I can't find another solution. Having 3 paths may be confusing it.
Also tried downloading the firmware file again and found there was an 08/2020 file.
Was hoping that would solve problem, but no luck.

Have seen several posts for same issue, but where it worked once, then didn't.
So, anybody have any thought or ideas?

TIA
 
Last edited:

ASK THE COMMUNITY