Question ASUS Prime x470-Pro Black Screen on entering BIOS...

Antrophin3

Honorable
Nov 24, 2015
12
0
10,510
0
CPU: Ryzen 5 3600 (Fabric clock + Memory working syncro @1600)
COOLER: AMD WRAITH PRISM (COOLER MASTER)
MOBO: ASUS Prime x470-Pro Bios Rev AMI v5406 - AMD AGESA Combo-AM4 1.0.0.4 (11/13/2019)
GPU: GIGABYTE WINDFORCE RX 5600XT 6GDR5

RAM: 4 x 8GB G.SKILL Aegis @3200MHz
NVME: ADATA GAMMIX S11L 512GB m.2
SSD: 1 x 720GB Gloway STK (SATAIII), 1 x LONDISK 960GB (SATAIII)
HDD: 1x WD RED 4TB SATAIII, 1x WD GREEN 1.5TB (SATAII)
PSU: Corsair AX850 Gold Certified Professional Power Supply
____

I recently bought this motherboard with Ryzen 5 3600 and Prism cooler for around 300€, and for the love of God i couldn't enter the bios... (pressing/holding DEL or F2)
Read a lot about this problems on other brands' mobo/cpu combos...
Every time i tried to enter it it just freezes on black screen and i have to restart.

I tried:
  1. Clearing CMOS,
  2. Unplugging CMOS battery for 15min,
  3. Turning PC off just after turning on (to force Computer imporperly shut down, press F1 to continue),
  4. Unplugged all USB peripherals, and tried using PS/2 keyboard (thought the issue was due to fast boot disabling USB initialization),
  5. Unplugging all sata disks,...
I managed to push my memory from 2133 stock to 3200MHz declared speeds (via Ryzen Master suite), it works fine.

How to update the BIOS for this board via Windows 10?
Do you think it will be problematic since it gives me black screen?
Please help. Thanks.
 

Antrophin3

Honorable
Nov 24, 2015
12
0
10,510
0
Thanks for your ideas. I managed to fixed it by updating via EZ update to version 5603 (07/08/2020)
Whoever upgraded it last time managed to bug it / it bugged itself.
 

ASK THE COMMUNITY