Question Asus Prime x570-Pro BIOS Freezing

Jan 22, 2020
1
0
10
0
Hi guys,
First time posting, this is my second build. AMD 3900x, 2x Corsair m.2 PCIe 4.0 in raid 0, 4x 8 gb gskill 3600 RAM, gigabyte RTX 2080 white OC edition, and the problem child; the Asus prime x570-pro motherboard. Built this set up about a month ago. Kept having POST issues which caused the BIOS to boot in safe mode after the second or even 5th + try. Sometimes it would say the CPU was the issue. Sometimes it would say the DRAM was the issue. (Via LED indication). Yes I tried each of the RAM cards individually. I tried with no GPU aswell (the RTX was never an issue with my old set up, ran it for about a year before upgrading cpu, ram and to m.2 SSDs). Had to put the project down over winter break to work and see family and now I’m back at school (I do a lot of solidworks, matlab, abaqus, aswell as gaming). Today I decided to update the BIOS to see if that was the issue with it not booting correctly. I used Asus’s EZ flash, which is built into the bios, with a USB and the most up to date version of the bios on the USB. It installed with no issues, no errors or crashes or interrupts. But now when I boot, the PC passes the POST with flying colors and immediately goes to the bios screen (where it displays ASUS and in fine print says “press F2 or DEL to enter BIOS”) which should display for only a few seconds before booting windows. Only issue is it freezes there. I’ve tried 2 different keyboards, both plugged directly into the MB, and had no response pressing F2 or DEL. If I leave it it’ll stay on this screen for hours. I’ve also tried unplugging everything even the back up battery and it doesn’t solve the issue. Any ideas? Or is this MB guna need to be sent in?
 

Barty1884

Titan
Moderator
Do you have DOCP enabled for that RAM to be 3600MHz? I'd be inclined to clear the CMOS, remove the RAM and install only 1x module. See if you can reach the BIOS at that stage and turn off DOCP.

At that stage, do you still freeze?
 

ASK THE COMMUNITY

TRENDING THREADS