Question ASUS Prime X570 Pro RGB on Linux

Nov 2, 2019
5
0
10
0
Hi,

I've recently built a new PC using the ASUS Prime x570 Pro as the motherboard and I've started having an issue with the RGB. When I initially built the machine I installed Manjaro Linux (on an M.2 SSD) which worked as expected the OS installed correctly and when I turned the machine on to use it the RGB lighting on the motherboard turned on as expected. Since then I've added a second M.2 SSD to the machine and installed Windows on there. When I initially installed Windows that to worked as expected. Turn the machine on everything loads and RGB comes on at the same time.

I've then installed rEFInd on the Manjaro installation to enable secure boot with Linux and have a boot manager appear to select the OS when I turn the machine on. Since doing that when I turn the machine on the RGB flashes and stays off until I boot and login to Windows. After logging into Windows the RGB will turn on and if I then reboot and go into Linux the RGB will stay on but if I boot directly into Linux the RGB stays off. Also the BIOS controls appear to have stopped working in that even if I boot into the BIOS the RGB stays of and changing the Aura controls in there appears to have no effect.

To do anything with the RGB I have to boot into Windows first then reboot into Linux. When I first built the machine turning the power on was all I had to do to get the RGB to come on but now I have to login to my Windows install for it to do anything. To be honest I don't really know where to start with it looking at the boot log for Linux this the below is the only error I can see relating to the RGB.

Any help or suggestions would be much appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS