Question Asus Prime z390-A bios keyboard Issues (solved)

Oct 31, 2020
4
0
10
0
Asus Prime z390-A Lga 1151​

Just bought the Asus prime z390-A mother board. Finish building it, but when I boot it up for the first time and try to get into the bios. It doesn’t detect my input on my keyboard ,I’m using a Corsair k70 lux and I connect it to the usb 2.0 on the motherboard. It detects it on screen (America Megatrends) along with everything else ( 1Tb m.2 , 6Tb HDD ,32gb ram, i9 9900k cpu). I also used a Razer deathstalker keyboard on the usb 2.0 slot on the motherboard, same result (nothing). I manage to find two old PS/2 keyboards and I plug them into the pS/2 slot on the motherboard. The keyboard lights up (well num pad lights) but when I press Del key nothing happens.

I tried to look up the problem on google and on YouTube and forums no luck. I even tried removing the battery on the motherboard for 3-10 sec. and putting it back in , and booting it back up and nothing. same problem.
 

boju

Titan
Ambassador
Sounds like the motherboard/cpu may not being powered properly and shuts down preventing you accessing bios. Or another hardware issue maybe.

Check power cables, ATX 24pin and CPU 12v. Try either only the m2 or HDD separately. CPU cooler is using the cpu_fan header?
 
Nov 1, 2020
1
0
10
0
Hey, remove the USB Dongles. If that doesn't work, check on the right side of your motherboard if their are any problems (LED) indicators will tell u.
 
Oct 31, 2020
4
0
10
0
Sounds like the motherboard/cpu may not being powered properly and shuts down preventing you accessing bios. Or another hardware issue maybe.

Check power cables, ATX 24pin and CPU 12v. Try either only the m2 or HDD separately. CPU cooler is using the cpu_fan header?
I have a 1200w power supply(I know over kill), and it’s connected properly. I have a kraken z63 and the fans for that is connected to the cpu fan header as well. I’m going to try to use the Clear RTC Ram jumper like it says in the manual.
 
Oct 31, 2020
4
0
10
0
I got it. I just plugged in the Corsair keyboard to one of the 3.1 USB on the motherboard and it worked. I guess I didn’t check All the USB ports. But thank you Boju & iForstMart for trying to help me out. I appreciate it.
 

ASK THE COMMUNITY