Question Asus prime z790-p and apollo x6-device not found

Jan 13, 2023
Hello. I have a new pc build for my studio. Its an intel 13900k with 32 gig of memory and an asus pride z790-p MB. My problem is that my new pc doesnt see my x6 apollo rack. in device manager its not there and in uad console settings i tried to add it but it says "offline". I have tried everything i can imagine. Newest bios, newest drivers both of uad and asus and intel versions. i have reseted my x6. tried to update firmware on both my thunderbolt card (asus thunderboltex 4) and my x6 but to no vail because it already had the latest fw.

I also have my older pc left and this i want to have at home. At home i have a apollo twin soundcard and when i connecting this little brother soundcard to my new pc build its no problem at all. The new pc find that soundcard. And when i connecting my old pc to x6 or for that matter the twin, no problem at all either. I have tried to installed both windows 10 and w11 for the new build but its the same, no x6 wants to load. I have the same settings in bios when i succeed to load the twin but can not load up the x6 rack.

I would so much apreciate any suggestions that can make me be able to use my x6. PLZ HEELP
Last edited: