Question Asus Rampage 2 Extreme - can you connect Rx 580

Feb 23, 2019
2
0
10
0
Hi guys,

Has anyone ever tried to add Rx 580 to older Asus Rampage 2 extreme?
I would like to run such card on this mobo until I get a new one in a couple of weeks, but I would get VGA bios error.

The complete specs are:
Intel Xeon W3565
Asus Rampage 2 Extreme
24GB G.Skill RAM
PowerSupply: FSP600-50ARN 88+
The GPU is Asus Strix RX 580 OC
PS - It also feels like the GPU doesn't fit in the PCI-E slot for some reason, even if the screw can be ... screwed in.
 

clutchc

Titan
Herald
If you have the latest BIOS for the board, I would not think there should be any problem with that card (unless the card is bad). I've run a RX 580 and other modern cards in my old Dell X58 board (Xeon X3650) in the recent past with no issues.
As to the ill-fit you mention, I'm not sure. Does it appear to be a mechanical issue? Card doesn't fully seat? Too long/short for the slot? Out of alignment?
 
Feb 23, 2019
2
0
10
0
If you have the latest BIOS for the board, I would not think there should be any problem with that card (unless the card is bad). I've run a RX 580 and other modern cards in my old Dell X58 board (Xeon X3650) in the recent past with no issues.
As to the ill-fit you mention, I'm not sure. Does it appear to be a mechanical issue? Card doesn't fully seat? Too long/short for the slot? Out of alignment?
Tested again today.
The small plastic part at the end of the PCIe sloth, used to "lock" the card was in the way due to the card shield. After little work it fit this time perfectly, but still no luck.
The power supply is enough after few test with my older card that consumes the same amount of power.
Played with the Bios settings some with no better results, still today found on the Nvidia forums that B2 revision of my Mobo would not work with Nvidia 1000 series and AMD RX 460 and up(my Mobo is B2 revision :( ) for most people a.k.a anyone who has seen the post, so it appears it is common problem, caused by the Chipset manufacturing.
Tuesday will try with another config with a Haswell CPU.
Thanks for taking a shot.
 

ASK THE COMMUNITY

TRENDING THREADS