Asus rampage IV extreme (black) - boot problem

Draakjuh

Reputable
Jun 14, 2014
3
0
4,520
1
Hello all,

I have a problem with starting up windows from my SSD. I have a new PC and installed windows 8.1 from a USB on the SSD (EVO 840 250gb). When I startup my computer, I see the republic of gamers screen and it asks me to press delete or F2 to go into my bios.

In the bios I have set the boot priority 1 to my SSD and 2 to my DVD drive (I have another SATA drive, but I have disconnected it). The SATA configuration is set to AHCI mode (also tried RAID mode). When I go to the boot menu and select my SSD, then Windows will startup normally.

Can anyone help me with this problem? I tried a lot, but still no luck. So every time when I start up my pc, is stays in the black screen asking me to press delete or F2 and I have to go to the boot menu to startup Windows.
 

Pinhedd

Polypheme
Moderator
Hi, new motherboards use the UEFI firmware interface, not the older BIOS firmware interface. Asus has included a compatibility support module in the UEFI firmware to allow for compatibility with older BIOS devices and operating systems that are themselves not UEFI compatible.

UEFI also changes the way the boot process is handled. It is now divided into "legacy" and "UEFI" boot methods. If both are active, one takes priority (which is selectable). It is recommended that the boot process be set to UEFI only to speed up booting and reduce problems such as this.

The legacy method enumerates attached devices in the specified boot order and scans the first sector on each one for a valid Master Boot Record. If an MBR is found, it passes execution to the boot loader in the MBR. If no valid MBR target is found, you will be presented with the infamous "no system disk detected. Please insert system disk and reboot blah blah blah".

The UEFI method scans attached devices for a valid GUUID Partition Table. It then enumerates bootable targets found across all valid GPTs and provides these for selection.

The key difference between the two is that BIOS boots to a specific device, and UEFI boots to a specific volume.

When you install an operating system on an uninitialized hard disk or SSD it first installs a partitioning scheme. The partitioning scheme can sometimes be chosen during the installation process, but may be defaulted or selected automatically. If the Windows installer is booted in UEFI mode it will automatically initialize an uninitialized disk (or an empty initialized disk) using the GPT scheme for use with UEFI computers. If the Windows installer is booted in legacy mode it will automatically initialize disks using the MBR scheme.

If this seems kinda confusing and problematic, you are definitely not alone. You have most likely installed Windows to a GPT initialized device, and then listed the GPT device in the legacy boot path. Since it's GPT, it won't legacy boot because legacy boot looks for MBR.

Instead, look for a boot target named "Windows Boot Manager" and place this at the top. If you see this, you can safely disable legacy boot entirely.
 

Draakjuh

Reputable
Jun 14, 2014
3
0
4,520
1


I cannot find the option to select 'legacy' or 'UEFI'. I unplugged now all devices (SATA). It sees the Samsung EVO 840, it is also has boot priority of 1 (in the boot option priority settings).
 

Pinhedd

Polypheme
Moderator


The settings will be under "Compatibility Support Module"
 

Draakjuh

Reputable
Jun 14, 2014
3
0
4,520
1


Thanks I found the options, but after changing them, it still doesn't work. What I found out is that my SSD is formated to MBR. I changed the settings to both Legecy and UEFI, but or the system gives me an error (that it cannot boot) or the same screen appears to go into UEFI BIOS.

At this moment I also unplugged all SATA cables and only plugged in my SSD inside the intel 6.0 slot (middle one). I tried a lot of settings at this moment. Inside the boot menu I can choose the SSD to start windows normally.
 

Similar threads