• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question ASUS ROG PG279Q periodically loses DisplayPort connection

Chziime

Reputable
Nov 20, 2016
25
0
4,530
0
Hi,

Once in a while, often when there is even a gentle touch to the monitor or even desk, my monitor loses signal and requires a lot of wiggling at the DP input to get it back on. After it finally comes back and remains on, my windows are often resized and GSync shows that it has been re-enabled. This sometimes even happens after turning on my PC, which is a major reason I rarely shut off my PC. This has been going on for a couple years now.

I purchased the monitor refurbished from Newegg about three years ago. This happens on both my GeForce 1080ti and old GeForce 960 with all outputs, on both the stock and a new, certified DP cable, and seems to be an issue with the monitor itself, or at least the DP input.

Admitted, I crossposted this from the Asus ROG monitor forum, but didn't get any replies there. I read on that forum that there is a firmware update that addresses a vertical line issue. I used to have this issue, often alongside the loss of connection, but I haven't had the vertical line in many months.

Is there anything I can do? I really like this monitor for video editing and gaming, and would prefer to not buy a new one just yet.

Thank you!
 

Chziime

Reputable
Nov 20, 2016
25
0
4,530
0
It seems to be more than that. Jerking the cable a little, even while it's still tight in the port, can trigger it. And unplugging and then pushing fully back into the port doesn't always do he job.
 

ASK THE COMMUNITY

TRENDING THREADS