Question ASUS ROG Strix B450-F Dead Dimm slot/mother board issue

Oct 22, 2020
1
0
10
0
Forgive me if I use the wrong nomenclature this is only the second PC I’ve built, and I had assistance. So, I purchased an Asus ROG Strix B450-F motherboard and it is refusing to post with anything in the fourth dimm slot. I’m using 4 x 8GB of ram (or at least I’m trying to) It will post with any other configuration. To elaborate on that it will post with a single stick in the A1, A2, B1 slots (or the first three) it also post with two sticks installed in any of those slots and all three slots having installed ram as well it recognizes all those sticks and posts with 24GB of RAM. However, any time I try to put the fourth stick in it won’t post, it doesn't matter the configuration just if anything is in the fourth slot it just sits there with the amber DRAM error light on the motherboard. I’m not sure what would be causing this (other than the board being bad) or what other trouble shooting I could try.

To list the things, I have already tried. I have tested each stick of ram individually and all worked and had the computer finished booting. I have loosened and retightened the CPU cooler bracket. I have blown compressed air in the fourth slot. I have removed and reseated all the RAM and switched the sticks around. I have updated the BIOS. I didn’t notice any damage when looking over the board before the install or during the install either. Any guidance would be greatly appreciated.

List of components:
ASUS ROG Strix B450-F Gaming (MB)
AMD Ryzen 5 2600X
G.Skill TridentZ RGB DDR4 3200 32GB (4 x 8GB)(RAM)
ASUS ROG Strix Geforce GTX 1070ti (GPU)
EVGA SuperNOVA G3 750 W 80+ (PSU)
Samsung SSD 860 EVO 500GB (SSD)
Anidees Al Crystal XL AR 3 ATX (CASE)
Corsair H100i RGB Platinum (CPU Cooler)
 

ASK THE COMMUNITY

TRENDING THREADS