Question ASUS ROG STRIX B450-F GAMING White light problem

Nov 28, 2019
1
0
10
0
i just got the last piece for my new built pc, i did all i had to do from what the manuals said, then turned it on and i have no video signal, i am getting that white led problem (VGA Problem)

my components are the following

CPU: AMD ryzen 2700x
MOBO: ASUS ROG STRIX B450-F GAMING Motherboard ATX, AMD Ryzen 2 AM4, HDMI, USB 3.1
RAM: Corsair Vengeance 8 GB, DDR4, 3000 MHz, 288-pin DIMM x 2
SSD: Kingston SA400S37
GPU: Gigabyte Nvidia Geforce Gtx 1050ti 4gb Ddr5
PSU: EVGA 600 BR, 80+ Bronze 600W, Power Supply 100- BR-0600-K1

1.Did you carefully read the motherboard owners manual?
yes, most of it

2.Did you plug in the 4/8-pin CPU power connector located near the CPU socket?
yes i did the 8 pins and 24 pins

3.Did you install the standoffs under the motherboard?
yes all of them

4.Did you verify that the video card is fully seated?
yes i did, it the video card i used on my other pc, i tryed it on all the 3 ports the MOBO has
, Update, i tryed with a second card, still same problem

5.Did you attach ALL the required power connector(s) to the video card?
this video card has no port for external power supply

6.Have you tried booting with just one stick of RAM installed?
Yes (update)

7.Did you verify that all memory modules are fully inserted?
if you mean the RAM, then yes, i removed them and placed them quite a few extra times just to be sure, the "clic" sound then you connect it was always there

8.Did you verify in the owners manual that you're using the correct RAM slots?
yes, as explained before, i tryed first on B1 and B2, then switched it to A2 and B2 (recomended on the manual)

9.Did you remove the plastic guard over the CPU socket?
Update. it had no CPU guard

10.Did you install the CPU correctly?
yes, i followed the steps the MOBO and CPU manuals said, but i can re try it if really needed (i dont really like to remove the CPU, i feel i might damage it while doing it)

11.Are there any bent pins on the motherboard/CPU?
no bends on any of the pieces, i checked them twice

12. If using an after market CPU cooler, did you get any thermal paste on the motherboard, CPU socket, or CPU pins?
i am using the CPU's cooler, it had its own paste on it, nothing on the pins, only on the top of the CPU

13.Is the CPU fan plugged in?
yes, the fan and LEDs from the CPU fan works

14. If using a stock cooler, was the thermal material on the base of the cooler free of foreign material, and did you remove any protective covering?
no foreign stuff on the thermal paste

15. Are any loose screws laying on the motherboard, or jammed against it? Are there any wires running directly under the motherboard?
all the screws are on their place, no screws on the MOBO, and no wires under the MOBO

16.Did you ensure you discharged all static electricity before touching any of your components?
yes, i am always afraid of static so i do it even if i am not going to touch any pieces

17.Did you check the debug LEDs, Q-code display, or install the system speaker (if provided) so you can check codes in the manual?
i dont have a Q-code display but the debug LEDs are kept on white (RGB problem as the manual says)

18.Did you read the instructions in the manual on how to properly connect the front panel plugs?
yes, and those are the pins where most of the build time took, i didnt want to mess so readed it like 3 times before doing it, and checked it every time i pluged something there

19.Did you turn on the power supply switch located on the back of the PSU?
yes... otherwise the white LED would not even turn on lol...

20.Is your CPU supported by the BIOS revision installed on your motherboard?
as stated on https://www.asus.com/support/cpu_support yes, it is supported

21.Have you tried resetting the CMOS?
yes, tryed removing the batery, and the plugs, and both together.... just in case

22. If you have integrated video and a video card, try the integrated video port.
ryzen does not have integrated graphics

23. Make certain all cables and components including RAM and expansion cards are tight within their sockets.
i did that already


just to end this, all pieces are new, aside the GPU, it works as it is the same i use on my other pc

in case i messed installing the CPU the error should actually be a never turning on pc right? if not then it is the only thing i am not really sure (the CPU and MOBO hast different installation methods)

sorry for my not so good english and typos...
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS