[SOLVED] Asus rog strix b450-f not showing splash screen on boot, and usb c port only functioning at usb 2.1 speeds

Jun 6, 2021
So I recently got a usb c to usb c cable for my oculus quest 2, I went to try it and it came back saying that i was running at a usb 2.0 speed, which shouldn't be happening, so I wanted to go to my bios and check, but when I tried that I got no splash screen and it went straight to windows. After that I went to disable windows fast startup, but no dice, it’s still acting like I have fast startup enabled. I even tried plugging directly into the mobo instead of my graphics card, but that made no difference. The only thing I can think of that could have to do with it is that I updated my Rx 5700’s driver before this happened. Additionally, after I potentially get this resolved and am able to access my bios, is there anything I could use in there to figure out why my usb c port is functioning as a usb 2 port? Thanks


Can you check and see what BIOS version you're on at the time of writing? You might want to also cross reference Asus support site for any BIOS updates. If you have a number of BISO updates pending, gradually work your way to the latest version. As for the quick bootup, can you parse an image of what you see in BIOS in BOOT section? Make and model of the cable? A link would suffice. Also, try and make sure that you've reinstalled the drivers for your chipset. When installing drivers, install them in an elevated command, i.e, Right click installer>Run as Administrator.