Question Asus ROG Strix SCAR III (G531GW) boot issue

DerRichter

Commendable
Jan 20, 2017
3
0
1,510
0
Hi guys! I have this Asus ROG Strix SCAR III laptop (32 GB RAM, GTX 2070, SSD 1 TB) for 1.5 months and didn't expect any problems with it till now. Yesterday night after Windows 1903 update I normally turned off the laptop and went to sleep. In the morning I tried to turn it on by pressing the start button, but the only result I got was a blinking keyboard, which turned red for a couple of seconds and then nothing happened. The screen was black and no ROG logo appeared. I tried pressing the power button multiple times, however, without success. So I started to research on Google and since morning I've tried the following:
  1. Holding the power button for 5-15-30-45-60+ seconds
  2. Disconnecting and connecting the AC cord
  3. Dismounting the battery and trying to power on only with AC cord connected
  4. Taking off RAM, m.2 drive and HDD
  5. Disconnecting the CMOS battery (was a challenge to find it and I had to disassemble the whole laptop)
  6. Plugging-in a USB stick with the latest BIOS version and trying to hit CTRL+Home button (anything happened)
  7. Combining all the above in different orders.
I gave it up and just left the laptop on my desktop. During the day I was trying to turn it on but didn't succeed. And then suddenly in 20 minutes after my last try, I pressed the power button again and it worked. The laptop started as nothing had happened. I restarted it a couple of times (wanted to update BIOS manually) and every time it ran great. So now I am typing from it and want to know, what the heck has happened and what should I do? The whole problem is I bought the laptop in Europe but will stay the next 2 months in Asia, otherwise, I just would send to Asus center. What could be the problem in my case and what should I do? At the moment it works, but I am very unsure about it now. Need help, please :(
P.S.: after my attempt to reanimate the machine my battery behaves strange: it shows the whole time, that it's not full and that it requires 10-15 more to be loaded, but with time the percentage doesn't change. Can it be fixed somehow?
 

ASK THE COMMUNITY

TRENDING THREADS