[SOLVED] ASUS ROG STRIX X570-E - USB 3.0 ports not working

Dec 20, 2021
8
0
10
1
I assembled a new PC with the X570-E GAMING motherboard. But if I connect one or both of the two USB 3.0 front panel connectors to the MB, the PC won't start. Not even the PSU fan will come on. If I remove the USB 3.0 connectors, the PC starts. The BIOS is the latest.

Are the USB ports just broken? What else can I do to verify? Is it time for an RMA?
Thanks.
 

piechockidocent9

Reputable
Aug 30, 2017
199
26
4,890
61
That would be a first to me . Difference between usb gens as far as I know is simply speeed (gen 1 up to 5gb/s gen 2 up to 10gb/s)so they should be perfectly compatible and in this case simply workingat weakest device top capacity so 5gb/s. Only reason I can think of that would cause issue severe enogh for the pc not to boot at all is again som fatal flaw in the mb or chassis, alternatively the psu but that's out of the question since you said urself pc boots fine as long as you do not connect the usb . Examine the usb 3.0 socket on the motherboard, no broken/bend pins in there by any chance?
 

piechockidocent9

Reputable
Aug 30, 2017
199
26
4,890
61
That's a toughie, from ur description ur rig fires fine minus the usb 3.0 so it's a problem with either the motherboard or the chassis usb 3.0 (which is quiten common). Unfortunately only way to know for sure I can think of to is it is to put ur config in anoteher chasis with usb 3.0 front panel and see. If it fires up fine then it's the chassis and if it doesn't it's the motherboard.
 
Dec 20, 2021
8
0
10
1
Unfortunately, that's the problem - my other case is 10+ years old (no USB 3.0) and this is the only AM4 motherboard I have. I was hoping to figure out some way, kinda like the "paper clip" test for a PSU.
 
Dec 20, 2021
8
0
10
1
Doing some more research, it seems there might be some compatibility issues. Case has USB 3.0 front panel. MB has USB 3.2 Gen 1 and USB 3.2 Gen 2. And it seems these are not compatible with the USB 3.0. Looks like I might need some kind of an adapter?
 

piechockidocent9

Reputable
Aug 30, 2017
199
26
4,890
61
That would be a first to me . Difference between usb gens as far as I know is simply speeed (gen 1 up to 5gb/s gen 2 up to 10gb/s)so they should be perfectly compatible and in this case simply workingat weakest device top capacity so 5gb/s. Only reason I can think of that would cause issue severe enogh for the pc not to boot at all is again som fatal flaw in the mb or chassis, alternatively the psu but that's out of the question since you said urself pc boots fine as long as you do not connect the usb . Examine the usb 3.0 socket on the motherboard, no broken/bend pins in there by any chance?
 

ASK THE COMMUNITY