Question Asus ROG Strix z390-e --- no POST, no display ?

Dec 2, 2020
1
0
10
0
Help.

My 1.5 yrs old build that I use daily stopped booting today. I noticed yesterday that the onboard Intel WiFi is not working so I just used a WiFi dongle but today I decided to fix it. I tried uninstalling the driver but it didn't work. I then did a hard shutdown by flipping the switch in the back of the of the PSU while the pc is on windows (not gaming, just idle). After that NO POST but the ram RGB and mobo RGB still lights up, fans also running.

Flipping that switch seems normal to me because I did that in the past a few times in this PC. And power outage is a norm here, like 10 times a month which this PC and my other 8 year old entry level PC has endured (on cheap antec psu).



I did troubleshooting in a breadboard setup.

Specs:
i7 9700k (not overclocked)
Asus ROG Strix z390-e
Gskill Trident Z 2x8gb 3000mhz
Seasonic Focus Plus Gold 550w
Cryorig H5 cooler
Palit GTX 1660 Super (not included in breadboard tests)


Troubleshooting I did:

- Removed all parts except a single ram and the cooler. Breadboard setup.

- Removed all connected cables and USBs.

- Used onboard graphics, tried both HDMI and Displayport.

- Reset CMOS. Removed battery, short the power pins, short the CMOS jumper. I did this many times and some combinations.

- Reseat the CPU and cooler.

- I don't have NVME SSDs installed.

- Tested 2 ram sticks, single stick at a time in all 4 slots. Power cycled a lot of times.

- Installed the PC/motherboard speaker
with single Ram, no beep.
without Ram, one continues and 2 short beeps.
- Motherboard QLED status:
CPU light on, then DRAM light on, but no light in VGA and boot.
- CPU fan and case fans will run in every boot.

- Trident Z Ram RGB will light up every boot.

- Motherboard RGB will also light up on every boot.
If I remove the 8-pin connector, it will not light up but still NO BEEP.
- Replaced the PSU with a very old Antec 550w 80+ bronze (still running daily in another computer), still the same, no display.
I used the Seasonic PSU in another PC and it's booting fine. I guess the PSU is working fine.
I switched these 2 PSUs trice.
Reseating the 24pin and 8pin multiple times.


Hope you can help me figure out if the CPU or the motherboard has the problem. Unfortunately I don't have another cpu or mobo to test.


Thank you.
 

ASK THE COMMUNITY

TRENDING THREADS