Question Asus RT-5300 issue blocking android phone updates


Dec 31, 2007
Is there a specific setting on the RT-AC5300 that affects phone updates?

{Backstory} So I bought my wife a used second phone, wifi only, to play games on. I factory reset and she added her accounts. When it tried to update a bunch of stuff, we left it overnight.

Next morning, nothing had been updated, everything says download pending. We both tried to update our phones (all 3 are galaxy S20) and got the same thing.

I thought maybe the service is down temporarily. We went to lunch and we were both able to update our phones on cell network.

So to get the play phone to update, I have to connect it to the OpenVPN service on the router i have for our kodi device.

The phones do everything else on the internet. I never noticed this before because we connect to other wifi networks during the course of the week.

Other devices:
Cable Modem - Motorola MB8600
If you had come here and asked how you could do that I would have told you that you could not. The router is pretty stupid and the update traffic should look like any other web traffic.

What this might be is a IPv6 issue. Android I don't know how to disable it. Most asus routers have a IPv6 thing under advanced setting where you can disable it. You should not need to use IPv6 and maybe there is some issue with the IPv6 network between your house and the update servers.
It should use normal IPv4 if you disable it.

If this doesn't make any difference then maybe it is DNS. Change the dhcp server setting so the router gives out or rather than the default which would be its own IP.