Question Asus RT-AC59U_V2 5ghz issue

May 21, 2021
12
0
10
0
Hello everyone this is my first post here.

I'm having issues on my newly purchased ASUS RT-AC59U_V2 router. When I connect to my 5ghz network, All devices is stuck at 802.11n and basically my devices wont negotiate at AC speeds as can be seen in the picture below. For this reason, I only get 72.2mbps link speeds which i assume is a very weird behavior. I have also tested between my laptop that is connected to 5ghz and a PC connected to the gigabit lan port using Iperf3 and the result is very poor. I have contacted asus about this just now and currently waiting for them to respond.

I dont have any 5ghz wifi around so all channel is clean. Another thing that is concerning me is that i can only run my router 5ghz at channel 149 and 153. If I set it to channel 36 the 5ghz wifi ssid wont show up. The available channels from the routers settings are 36, 40, 44, 48, 149, 153, 157, 161, 165.

Please help if anyone know about any settings or configuration that i can try.

My network adapter information




My Iperf3 result



My Asus Router Settings
 
I agree that is very strange.

Now it is unlikely but is there any setting in the wifi nic that you set stuff like 802.11n or maybe 20mhz channels. You want to leave all this stuff on the default or auto setting really.

So what 72.2 means is you are only running 1x1 mimo on 20mhz radio bands.

The 1x1 mimo you can't fix since that is a restriction of your nic card. What you should be able to get is faster rates using 40 or 80mhz radio bands. If it was 80mhz you would get a 433 connect rate.

I suspect this might be cause by your router. I never understood the channel numbers since they are used inconsistently between routers. BUT in this case the numbers you list represent the center numbers for 20mhz radio bands. Some routers you would put in say 151 for 40mzh and 155 for 80mhz. Not all routers work that way though. Some if you pick any channel and then set the radio to say 40mhz it will pick the closet block.

Can you leave the channel number blank or is there some method of letting it auto assign all this stuff.
 
May 21, 2021
12
0
10
0
I agree that is very strange.

Now it is unlikely but is there any setting in the wifi nic that you set stuff like 802.11n or maybe 20mhz channels. You want to leave all this stuff on the default or auto setting really.

So what 72.2 means is you are only running 1x1 mimo on 20mhz radio bands.

The 1x1 mimo you can't fix since that is a restriction of your nic card. What you should be able to get is faster rates using 40 or 80mhz radio bands. If it was 80mhz you would get a 433 connect rate.

I suspect this might be cause by your router. I never understood the channel numbers since they are used inconsistently between routers. BUT in this case the numbers you list represent the center numbers for 20mhz radio bands. Some routers you would put in say 151 for 40mzh and 155 for 80mhz. Not all routers work that way though. Some if you pick any channel and then set the radio to say 40mhz it will pick the closet block.

Can you leave the channel number blank or is there some method of letting it auto assign all this stuff.
Thank you so much for the insightful reply. You're absolutely correct my laptop has 1x1 antenna. and i get it now why is the link speed is like that. Now what I think is the problem is that my router will only negotiate with 20mhz channel width and wont do 40 or even 80 mhz channel width. I tried auto everything my 5ghz didnt even show up. it only show up if i set the channel to above 149. is there anything i can do to make my router do 80mhz?? I tried forcing 80mhz still does 20mhz.
 
May 21, 2021
12
0
10
0
I found additional information on my syslog if it may be useful

May 21 19:30:38 kernel: ---- ACS CALCULATE ----
May 21 19:30:38 kernel: Chan 1 pre_param 11 param 11
May 21 19:30:38 kernel: Chan 6 pre_param 5 param 5
May 21 19:30:38 kernel: Chan 6 pre_param 5 param 5
May 21 19:30:38 kernel: Best Channel Selected 6
May 21 19:30:38 kernel: ieee80211_derive_chan : Overriding HT40 channel with HT20 channel
May 21 19:30:38 kernel: __ieee80211_smart_ant_init: Smart Antenna functions are not registered !!!
 
May 21, 2021
12
0
10
0
Not sure I would say that is not english but I guess it really is.

Those channel numbers are related to the 2.4g band I would think.
I really don't know either. I think what's best is to check Asus' response on my email maybe they will upgrade my firmware or something.
 
upgrade the firmware is always good thing to try when you get strange results. This is one of the big reasons you pay extra for a company like asus or tplink there software support is much better than the cheaper brands.

I think you can directly upgrade the firmware using the router itself but if not you can always go to asus site and download the file and then tell the router to load it off your PC. It is pretty simple on asus routers.
 
May 21, 2021
12
0
10
0
upgrade the firmware is always good thing to try when you get strange results. This is one of the big reasons you pay extra for a company like asus or tplink there software support is much better than the cheaper brands.

I think you can directly upgrade the firmware using the router itself but if not you can always go to asus site and download the file and then tell the router to load it off your PC. It is pretty simple on asus routers.
sadly this is the latest firmware from them... i had a tplink Archer C80 and it's spitting out the same result too... I hope they will patch this problem really soon. thanks for the help man
 
What is strange is for most people they take the router out of the box do not set any channel or anything and it just magically works for them.

If it is multiple routers then I would go back to suspecting the nic card. I would look through the settings and see what happens if you change stuff.

I really wish there was some debug mode where you could watch the negotiations of the speeds but for some reason the chipset providers think us end consumers do not deserve access.
 

ASK THE COMMUNITY