Question Asus RT-N66U & RT-AC66U AP coexistence


Oct 2, 2008
I have a current set up of two Asus RT-N66U routers. One performs the function of router/gateway/dhcp with radios off, the other handles the WAP duties.

Tl;Dr - - my n66u 2.4g channel disappears after activating the ac66u with matching ssid, security and psk. I set them to operate on n-only and n/ac respectively with b/g blocking on both.

#1 RT-N66U: Router mode w/dhcp on, radios off
#2 RT-N66U: AP mode with 2.4 and 5 radios on; guest network active on both radios for the primary connection. Connected #2 lan port to #1 lan port.

It all works great as is. My only issue with this configuration is that the peak number of users has outgrown the AP's ability to sustain all simultaneous connections, thus at peak times randomly kicks users off and on. To solve this, an Asus RT-AC66U was obtained to help balance the load.

Enter #3 RT-AC66U: AP mode with 2.4 and 5 radios on; guest networks are active on both radios for primary connection like #2. Connected #3 Lan port to #2 Lan port.

For privacy, xxx and yyy are used as variables to mask. SSIDs and PSKs of both match for seamless connection without users needing to connect twice. Guest networks are required for our general users to protect user privacy.

In general, we are on a /24 subnet with each router assigned static ip x.x.x.1, x.x.x.2 and x.x.x.3 respectively. Dhcp doesn't start until x.x.x.10 to allow for certain devices.

Set radio configuration on #2:
2.4g: ch.11, 20/40 width, n-only, block b/g on, ssid "xxx", psk "yyy", Auth WPA2 personal
5g: ch. 142, 20/40 width, n-only, ssid "xxx 5", psk "yyy"

Set radio configuration on #3:
2.4g: ch.3, 20/40 width, n/ac, block b/g on, ssid "xxx", psk "yyy", Auth WPA2 personal
5g: ch. 36, 40/80 width, n/ac, ssid "xxx 5", psk "yyy"

After changing all settings such that they should play nicely together, I restarted them both. Once they come back up, the #3 AP works exactly as expected, survey shows both bands running.

This is the problem - - The #2 AP ch. 11 2.4g band is gone as viewed on wifi survey app. #2's 5g band is broadcasting fine. In the router's wireless config panel the only radio I can choose is the 2.4, but all my other settings are for the 5g range like ssid and channel.

I can ping the internet when connected to only the #3 router and vice versa, not really a required test but did it anyway FYI. I've started from scratch several times and every time it does this. I'm not sure that it's even an issue with the majority of devices being dual band capable now. It mostly just bothers me because with two dual band routers I should get two dual band signals on opposing channels.

Anyone know anything I may be missing with the quirks of these two devices operating together?
I would change the SSID to be different just so you know what device you are looking at. It could be the scanner software.

I would test each AP with the other one turned off just to be sure they function correctly independently.

Part of your issue is it is impossible to have 2 router coexist on the 2.4g band unless you force them to 20mhz support....which reduces your top speed. There is only 60mhz total so 2 40mhz will not fit. The channel numbers in the router only represent 5mhz of bandwidth so a 40mhz signal need 8.

You can also reduce the radio power so they do not interfere as much but if you have them sitting next to each other that is not real useful.

Another note on your configuration. The guest function will either not work or is worthless for security when running as a AP. Depending on the router it will either not allow any traffic to talk to other lan machines which means it can not talk to your main router or it will allow the traffic which means it can talk to ALL your other machines. Guest only really works on consumer router when it is run on the main router that has the internet connection.

Maybe consider a single more commercial AP like the ones from unbiquiti. Still even most consumer routers should not drop wifi connection because of too many clients. Most times you just run out of bandwidth and it runs very slow but that is more dependent on how much traffic the end clients use rather than the actual number.


Oct 2, 2008
You're absolutely correct about the channel width, didn't even think about that. And it would not make sense to run them at 20, defeating the purpose of the second ap. I'm certain the router in ap mode is intelligent enough to know this which explains the bizarre behavior.

I did try isolating them just to check that part, but not with different names just turned the radios off on the one opposite of what I wanted to test.

Didn't know that about the guest mode though. The isolation only happens when used on the wan router, which also makes sense as explained. Why would an AP need to isolate connections since it's already on a trusted network, just making wireless connections to it.

Thank you for the comments, I'm pretty sure that addresses the main issue and confirms my suspicion that the routers were not playing nice somewhere. I may look into a ubiquiti wap at some point.
Thread starter Similar threads Forum Replies Date
AtotehZ Wireless Networking 3