Question ASUS RX 570 EXPEDITION OC 4GB: No signal

Feb 21, 2021
2
0
10
0
Hello!
I purchased a used ASUS RX 570 EXPEDITION OC 4GB about two months ago, which I plugged into my main computer and worked fine. It gave very good performance, no instability or any other issues. According to the seller, the card had been used about half a year with Media Center use (I don't know what this means).
About half a month ago, while playing a game (FiveM - GTA V) with Discord running in the background, screen went black and the No signal message appeared. There were no other symptoms prior to this. From that point on, I would not see image from this card again. PC boots and loads Windows properly, but it seems no signal comes out from the RX 570. At first, I used Windows Narrator and TeamViewer to be sure Windows boot, and they do. Then I realized that I could get image if I plugged the DVI cable to the onboard graphics card.
I mentioned Discord running in the background, because this issue occurred about half an hour Discord was installed on this PC, it was running at the moment of failure and some people online hint that there is a weird setting it has (Hardware Acceleration) that may interfere with the graphics card. I don't know more on this.
There is no signal at all, neither at boot (eg BIOS post, etc). Windows detects only the on-board graphics card in Device Manager and "AMD Radeon Settings" option has disappeared from desktop context menu.
No visible damage is seen on the card.
The card's white led is ON when the 6+2 pin is connected and I have noticed that the fans spin for about a second when pressing the PC power button and then stop.

Here is the troubleshooting steps I have already done:
  1. Open and clean card with tooth brush, remove old paste and apply new.
  2. Reseat the card many times.
  3. Reset motherboard BIOS by removing battery, loading BIOS defaults and shorting the reset pins.
  4. Try the card on another PC (probably incompatible motherboard).
  5. Load BIOS Fail-Safe Settings.
  6. Disable onboard graphics via BIOS.
  7. Set INIT FIRST DISPLAY to all options (PCI, PEG).
  8. Test with both HDMI and DVI (but not D-SUB).
  9. Uninstall drivers and Adrenalin software (using the official uninstaller in Safe Mode) and reinstall latest from AMD website.
After the RX 570 failed, I plugged in my old card, Radeon R7 240. The first day I experienced weird graphics issues with this card (it worked fine before upgrading to RX 570), such as screen flickering and going up and down, white lines, etc. This stopped by removing the R7, plugging into another computer to test it and then on mine again.
There was a hint that the PSU may have failed, so I purchased a new one: Thermaltake TR2 S 700W. The RX 570 didn't work with this as well. It switches to on-board graphics.
The other computer I tested the card on has an HP MS-7863 VER:1.1, so I'm not sure if the test on it was worth, as it may be incompatible with the RX 570 (?).

Below are my PC Specs:
  • Windows 10 Pro 64 bit
  • AMD FX-6300
  • 8,00GB Dual-Channel DDR3 @ 801MHz (11-11-11-28)
  • Gigabyte Technology Co. Ltd. GA-78LMT-USB3 6.0 (Socket M2)
  • 4 hard disks (1 SSD, 3 HDD), 1 CD drive
Do you think there is something more I can try before declaring the card as dead?
Some people mention that there is a BIOS switch on the graphics card but I cannot see one.
Could be a corrupt graphics card BIOS? (However, I can't think how could this be, since I never flashed it or messed up with such things).
Could the other slot (I think PCIe X1) on my motherboard be used to test the card (I don't know even if it fits; I have not tried)?
Since the card did not work on the other PC with the HP MoBo, should it be certainly considered a graphics card failure, or maybe it is just not compatible with that motherboard?
Would updating MoBo or graphic card's BIOS do any good in this situation?
What else could I try to do to make it work again?

Any help would be highly appreciated!

Thank you in advance
 
Last edited:

ASK THE COMMUNITY