ASUS Sabertooth X79 BIOS Flash

Hel Styrkr

Mar 18, 2012
Hey all. I just wanted to take a second and post this and hopefully save everyone some time and headache. This has been verified tested by myself on my new build with a ASUS Sabertooth X79 and 16GB (4x4) G.Skil 1866 DDR3 RAM. The problem I was running into was that after assembling all of the computer components, I could not get the ASUS Sabertooth X79 to POST. It was getting power, but there was a solid red LED notifying me of a DRAM error. I ran through the troubleshooting guide with no luck. Contacted the ASUS and G.Skil customer service, with no luck. After doing some research on google, I found this from "dyrby76" over at the Corsair forums.

"With the Sabertooth X79 motherboard it doesn't recognize the Corsair RAM or most of the other normal brands of RAM out of the box. You must manually flash the BIOS to the latest version before it will recognize the RAM."

1. Go to ASUS homepage and download the latest BIOS. Get it here:
2. Download the newest version, (for me it was version 0906) and put it on a USB jump drive in the root directory with nothing else on that USB jump drive.
3. Rename the file to "SABERX79.ROM".
4. Now insert the USB stick in the back of your motherboard where it has a BIOS button. It has a white box circling the USB to insert it in. All you need to have is the motherboard and the power supply, nothing else is required to be connected.
5. Don't try to start the computer, just have the power cord hooked up. The green light on the motherboard lights up to show you have power.
6. Now all you do is press the BIOS button and hold it for 3 seconds or so. It will start to flash. Leave it alone until the blue flashing light on the BIOS button shuts off.
7. Now you can take out the USB stick and turn on your computer. It will now recognize your Corsair RAM and any other brand you may use.

Again, all credit for this goes to "dyrby76" over in the Corsair forums. I'm only the messenger spreading the word, and hopefully this will help someone. Good luck!


Jan 3, 2013
Sorry to dig up an old thread...
I'm having exactly the same problem, although I can't get the USB bios flash to work correctly.

I've tried using a 16GB, 8GB, and 4GB usb stick. I called tech support and he said the smaller the USB stick the better.

I get the LED light to blink 4-5 times then it says steady and doesn't turn off. I tried resetting CMOS, formatting in FAT16 and FAT32, using the BIOS renamer vs manually renaming. I can't think of anything else to just won't flash the updated BIOS.

If the motherboards are that picky about USB drives, you think ASUS would include a cheap 1GB with the mobo. This has been extremely frustrating.


Aug 14, 2009
I have somehow a question about my Bios bios LED keeps flussing blue out of the box...!!! I don't need a bios update but do anyone know how to turn off that bios LED from blinking blue !!?
I try resetting the PC by unpluging the power cord for 5 min...No luck that thing keeps blinking none stop...even when my PC is turned OFF :-/