Question Asus Strix B250F Gaming 16gb 2x Ram Error Light HELP!

Jul 21, 2020
4
0
10
0
Hi guys

I seen a similar thread last year on the 450 but mines is slightly different to the issues on there. I installed the new (Opened box) motherboard I purchased on Ebay everything seem to go well then was getting the red to orange light on the ram managed to get it randomly working but only read 1 of 2 8gb crucial sticks. Updated the bios etc and thought maybe a ram issue as its old just got 2 new sticks today same thing again although 2 and 4 dont work 4 works on its own (furthest away from cpu) and 1. tried 1 and 3 but still orange light and no bios or loading visuals on monitor!

I dont know if board is goosed or has an error the bios seemed to work fine and has updated to suit to the latest BIOS 2018 i think it is.

I have an intel I5 7400 CPU in just now which was working fine in my old MSI atx pro vd board along with the same fans etc. No beeps etc just red to orange or orange lights. When just one is in 4 its green then white and can load the bios etc.

Any ideas? Problem is was hard to get a 6/7th gen motherboard and was from a private seller on ebay so need to try to sort asap or open a case as its been sitting in box for a year apparently new. Only thing I did notice on the other thread the guy mentioned about pins on motherboard, my case had 4 around the perimter there seems to be some required in centre Im not PC clued up that way so I dont think this should make a difference but thought I would add anyway incase its triggering something.

EV
 

Lutfij

Titan
Moderator
The board has names for the slots that need populating first. According to the manual, here page 1-5, you should be populating slots A2 and B2. That being said, which BIOS version are you currently on? I would ask you to breadboard the system and also list the rest of your specs.

Please include/list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
GPU:
PSU:
 
Jul 21, 2020
4
0
10
0
Hi Lutfij,
Thanks for getting back I tried that made suer theres no dust and tried to add to slot 4 first then reboot and add the second to slot 2 A2 and B2 but only works on slot 4 single.
I am using firmware bios - STRIX B250F GAMING BIOS 1207 the latest one after having to use 1 slot of ram I originally had 2x working crucials on 2133 mhz and purchased and tried 2x 8gb Corsair Vengeance DDR4 3200mhz sticks today same again one but not 2 together in the required slots


Please include/list your specs like so:
CPU: Intel I5 7400
Motherboard: Asus ROG Strix B250F Gaming
Ram: Corsair Vengeance 8gb 3200mhz 2x 8gb or 2x crucial 8gb 2133mhz
SSD/HDD: Tororus 256gb SSD / Seagate 2tb HDD
GPU: AMD Radeon RX 5600 XT Card (Gigabyte)
PSU: TBC
 
Jul 21, 2020
4
0
10
0
Update - So got the 2400 Corsairs to try but still the same issues - Also got my I7 7700 in today as well and will try to install that tonight and give it another go as its still doing the same with the B2 slot ok with one getting visuals and booting up but A2 doesnt like and orange Dram LED and not boot up allowed with the 2400mhz corsair and I5 7400 CPU.

Weird thing is when I got the main screen I slotted ram into the A2 slot and opened speccy application and its there 16gb ram A2 and B2 so its reading just not allowing it to boot any ideas? I need to return the motherboard by the weekend otherwise to allow me to get money back but would rather keep it save the hassle etc if its not faulty!
 

ASK THE COMMUNITY