Question ASUS Strix X570-E Gaming --- Installation of some software causes black screen and reboot ?

Nov 28, 2020
2
0
10
0
The machine is running Windows 10 and the latest updates as of 11/23/20. ASUS also had a BIOS update at the time and after the Windows updates installed I updated the BIOS to 2812. I noticed after that, the utility for my Nu Audio sound card wasn't popping up on boot and wouldn't load. I tried to reinstall it and it wouldn't do anything, just sat without installing. I tried to bring up Armoury Crate which is the ASUS update utility for drivers and all and it wasn't working. I uninstalled it and tried a reinstall and immediately when it started it gave a black screen and rebooted. I then tried the Nu Audio utility and got the same results, black screen and reboot. Ive since tried reloading windows and reinstalling it all still no luck.

The same happens when I try to install the Windows 10 SDK both directly and off an iso disk. Other apps seem to work fine. It seems those installs are trying to access a resource and the machine isn't happy. The processor is an AMD Ryzen 5 3600X with 32 gb of memory. Any ideas on what I can try?
 
Nov 30, 2020
4
1
15
0
Nov 28, 2020
2
0
10
0
Try this, just in case:
Hi Tim;

Thanks for the reply. I dont overclock the machine and I was assuming those were settings in either the BIOS or in Ryzen Master. I'm not clear on what settings to change or exactly how to set them. Im not that familiar with procedures for overclocking. If you could indicate which settings require changing (ECD current limit is what in the BIOS?). I'm running 2816 BIOS now too.
 

ASK THE COMMUNITY

TRENDING THREADS