[SOLVED] Asus TUF B450-plus motherboard blinking red.

Nov 4, 2020
29
2
45
1
It is my first time build. Prior to this asus motherboard I had gigabyte Aorus b450 motherboard and it made cpu fan run for a second and stopped immediately and was blinking red forever. I thought there has to be a defect in motherboard thinking probability of having my ryzen 7 2700 processor was very low, so I replaced it with another, replaced motherboard wad dead on arrival. Now it's been I guess 2 weeks I've got this new asus tuf motherboard which is blinking red after 10 seconds when psu power switch is turned on.
I've noticed these things:
  • nothing powering up, not even psu's fan spinning apart from motherboard's rgb light.
  • motherboard runs a rgb light along the side for 10 seconds but nothing powers up not even power switch led then motherboard goes blinking red.
  • power switch on the case is not showing any light and not even doing nothing despite I connect respective cables into motherboard which I'm testing outside the case.
  • tried to boot system with all components- same error.
  • tried to boot up without gpu and with only single ram stick, cpu, cpu fan - same error.
Please help :(
 
Last edited:

RealBeast

Titan
Moderator
While everything else looks fine, I do not see your memory on the motherboard QVL, and the B450 boards (all brands) with Ryzen CPUs seem to be pretty particular about memory.

You should contact HyperX support for recommended settings or an exchange if they do not work as many other sets have not in my experience. The problem is often that you cannot change bios settings for the memory to try for better compatibility since it won't post.
 
Nov 4, 2020
29
2
45
1
Please list the full model number of your key parts, including memory (full model #), PSU, and GPU.
Specs are:
Memory - HyperX Fury 8GB DDR4 3200MHz * 2 stick, model no. - HX432C16FB3/8
PSU - Corsair CV550, model no. - CP-9020210
GPU - Gigabyte GTX 1660 super 6GB OC edition, model no. - GV-N166SOC-6GD.
Appreciate your interest
 

RealBeast

Titan
Moderator
While everything else looks fine, I do not see your memory on the motherboard QVL, and the B450 boards (all brands) with Ryzen CPUs seem to be pretty particular about memory.

You should contact HyperX support for recommended settings or an exchange if they do not work as many other sets have not in my experience. The problem is often that you cannot change bios settings for the memory to try for better compatibility since it won't post.
 
Nov 4, 2020
29
2
45
1
You should contact HyperX support for recommended settings or an exchange if they do not work as many other sets have not in my experience. The problem is often that you cannot change bios settings for the memory to try for better compatibility since it won't post.
Great! Thank you for figuring out.
So what should I include in query? like, exchange existing ram for a different compatible ram model?
 
Nov 4, 2020
29
2
45
1
Yup, that is exactly what I would push for since the memory industry has not been actively transparent on compatibility IMO. Often G.Skill will do that, which is why I'm a big fan of their memory.
Is it possible for them(HyperX service) to get the memory base clocked at certain value where my motherboard is compatible with it? say 2666MHz.
Or my current memory is totally incompatible and I'll have to get exchange for a different model with features degraded?
Is that my fault I didn't check out motherboard QVL and now I can't defend my side?
 
Last edited:

RealBeast

Titan
Moderator
It's just been one day I bought this ASUS motherboard, so should I return this one and get the MSI TOMAHAWK MAX B450 chipset motherboard assuming motherboard's QVL supports -> HX432C16FB3/8.
And importantly I have 2 sticks of this model bought separately.
I think reaching out for memory's RMA should be last option to try out
MSI TOMAHAWK MAX B450 memory QVL - https://www.msi.com/Motherboard/support/B450-TOMAHAWK-MAX#support-mem-14
That memory is on the QVL for that motherboard with a Matisse CPU (Ryzen 3XXX) so that should work.

One word of caution though: in the future always buy your memory as sets rather than individual sticks. I don't expect it will be a problem here but that is always possible.
 
Reactions: Epicguy12
Nov 4, 2020
29
2
45
1
Help! I got new MSI b450 tomahawk max II, but it's not booting to BIOS, it is showing CPU EZ debug led and the led disappearing in 2 minutes and throughout this whole sequence I'm not getting any display with HDMI from gpu. Everything is starting up like cpu fan, gpu fan, motherboard lights, cabinet power switch led except for display.
Please help :(
 

ASK THE COMMUNITY

TRENDING THREADS