Question Asus Tuf gaming B550 plus DDR4 3200 ram issues

Dec 9, 2021
3
0
10
0
Please help this is my first post .so I'm having ram issues on my b550plus. I read some where the the Corsair Vengeance pro RGB 3200. I started with 4 8 gig sticks which worked fine for a couple months then 2 of the slots stopped recognizing it . It would show the RGB lights and I did try different slots. Which all seemed to work but now only it the first 2 closest slots to the cpu. Which is a1& b1 . I believe that's incorrect but that is the only why I could get it by to work . . So yesterday it crashed so I went and bought 4 16 gigs sticks of vengeance lpx DDR4 3600 . . I can't get my system to boot. I've tried each of one stick which everything turns on except the monitors .I get a yellow light and then red with one stick . I've tried resetting cmos with screwdriver also I've pulled the onboard battery. I don't know what else to do. I'm upset and am ready get a new board if I can't figure this out . Pleaseee help
 
Dec 9, 2021
3
0
10
0
I can get everything to boot except the display kb and mouse . I've manage to get the graphics fans to tur on along with all the others and cpu and the rbg lights from the 2 ram sticks I had in it the cosiar 3200 . Which initially I had 4 sticks for a couple months with no problems then I can no longer get the right 2 slots furthest away from cpu no longer will register. The RGB lights will but that's it. It won't boot and if I have more then 2 sticks In the video card fan don't run . No I can't seem to get into bios I wish. My last crash consisted of apex wasn't on long. I don't recall a bsod but it did crash and wouldn't post boot to bios even now. .. not sure what bios version i have . I might be able to check ?
I have the
Asus Tuf Gaming b550 plus
Cpu : Ryzen 5 3500 x
Heatsink :Cool master liquid cooled heat sink
PSU :Corsair cx650f RGB
Graphics: MSI Radeon 570 rx Armor
Ram : Corsair Vengeance RGB pro 8 gig x 4.

This ram should be compatible which worked just fine for a few months not sure what changed at that point I lost my 2 right ram modules but was still able to use the 2 on the left which I kno isn't suggested . I don't know much about ram and I don't know where I went wrong . I read sum where the 3200 isn't good for the board which isn't what the manual provides . So I'm have the point of just getting a new board cuz I think I fried my modules some how , even tho I can get the RGB to light up in them ... Thanks for your time patience and help
 
Dec 9, 2021
3
0
10
0
So I figured out what I did wrong , I wasn't aware that amd and Intel prefer defferent speeds. I used 4 sticks of ddr 4 3200 on my amd cpu which requires 3600. Which doesn't recognize even the 3600 now . I'm assuming I messed up my memory modules or cpu . . I about to get a new board . I just hope I didn't damage the cpu
 

ASK THE COMMUNITY