Question Asus Tuf Gaming B550 Plus No POST - BIOS Flashback Issue

Dec 20, 2020
1
0
10
0
I am just 'finishing' up a PC build and am running into a problem at the POST stage. Here are the parts:

Asus Tuf Gaming B550 Plus,
AMD Ryzen 5600x,
T Force 3200 MHz 32 gb RAM kit,
Samsung evo 970 1Tb SSD,
Seagate Barracuda 2Tb HDD,
Radeon RX 5700xt,
evga 650 watt psu,
Corsair 220T.

So with the ryzen 5600x I have to do a BIOS flashback which this motherboard supports. I have a flashdrive with the proper bios downloaded with the correct naming for the CAP file and formatted FAT32.

When I plug everything in, all the RGB lights up and the fans spin. The GPU lights are also on. The problem is that the monitor says that it is not receiving HDMI signal. However, if I unplug the HDMI cord the monitor goes blank for a second and says lost signal, so it must be receiving some information from the GPU. Seems odd to me.

Additionally, there is a motherboard error light for DRAM. I re-seated the RAM and tried single stick by stick- still the light is on. I went ahead and tried the BIOS flashback because apparently sometimes with the BIOS flashback issue it shows up as a DRAM light? So I press the flashback button for three seconds and you are supposed to see a amber light on the motherboard by the button. However no light appears no matter how long I hold the button.

I do not have another RAM set or old gen AMD CPU that I can try to POST with. Does anyone know what the issue could be? Does it seem like a RAM issue or the BIOS flash issue? I wore a anti static wrist band and touched the case before handling the MBO each time so I am quite confident that the MBO isnt fried or anything from my handling- also everything lights up and spins.

Any help is much appreciated
 
Jan 4, 2021
1
0
10
0
I was encountering this problem today with the same Motherboard/Processor combination you have. I eventually figured out how to this issue.

The issue is that the BIOS version is old and won't work with the processor. So you must install a new BIOS before being able to boot properly. To do this you can use a USB stick and flash the correct BIOS onto it. Google for the links and you'll find them. Once the USB has the BIOS inside place it inside the USB port that has the BIOS symbol on it (or look at your motherboard documentation). Click the button behind the motherboard for 3 seconds and it should start flashing more. This means the BIOS is updating. Mine took around 5 minutes to install.
 

ASK THE COMMUNITY